Announcement

Collapse
No announcement yet.

Fulltext search not enabled (having created indexes etc.)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • urban75
    replied
    Its ok I found it and Fulltext searching is now ON thanks.

    Leave a comment:


  • urban75
    replied
    If I knew where the internal switch was I could flick it myself. (I am fairly adept with PHP and MySQL)

    Leave a comment:


  • Colin F
    replied
    I recommend you open a support ticket first, as all that actually still has to be done if you already have the indexes is change the internal switch, which would most likely allow you to not have any downtime.

    Leave a comment:


  • urban75
    replied
    We've decided to close the live boards again tomorrow morning and try pressing the 'Go' button. If that doesn't work we'll raise a support ticket.

    I guess I will need to drop the 2 manually created indexes first?

    Leave a comment:


  • Colin F
    replied
    Yes, it would try to rebuilt the indexes.
    Could you open a support ticket and provide your AdminCP and FTP login information please?

    Leave a comment:


  • urban75
    replied
    But... does pressing 'Go' try to rebuild the indexes?

    I pressed 'Go' to begin with but owing to timeouts and diskspace issues (had to free up some) I ran the queries manually.

    I really don't want to rebuild the indexes again. We have to turn off the live boards for this as the db grinds to a halt.

    Leave a comment:


  • Colin F
    replied
    You'll have to actually switch to fulltext searching in your

    AdminCP -> vBulletin Options -> Search Type, by clicking on the [Go] button.

    Leave a comment:


  • Fulltext search not enabled (having created indexes etc.)

    PHP Version 4.4.2
    MySQL 4.0.26
    FreeBSD 4.1

    Upgraded our test site from vBulletin version 3.0.7 to 3.5.4.

    Ran the following queries manually:
    ALTER TABLE post ADD FULLTEXT INDEX (title,pagetext)
    ALTER TABLE thread ADD FULLTEXT INDEX (title)

    Verified in phpMyAdmin that the indexes were created:
    thread table (86,959 recs): title FULLTEXT 28986 title
    post table (2,773,846 recs): title FULLTEXT 924615 title pagetext

    (Is that post index the right size do you think? the index query ran without error)

    In the Admin Cp, Index New Posts in Search Engine is set to Yes for each forum (although this is the test site so there are no new posts) and Message Searching Options:Search Engine Enabled is set to Yes.

    Despite all of this, the vBulletin->Options->Search Type still says "Your forum is currently using the vBulletin search engine. "

    What can I do to use the Fulltext Search Engine?

Related Topics

Collapse

Working...
X