Announcement

Collapse
No announcement yet.

Increasing Number of Database Errors

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Increasing Number of Database Errors

    As my traffic continues to grow, I'm increasingly seeing more and more of these error messages on a blank white screen:

    "There seems to have been a problem with the database. Please try again by clicking the Refresh button in your web browser."

    It's to the point that I see this every 5-6 pages in the forums now. I've recently implemented a couple of custom templates that allows members to login/logout/check PMs from any page on my entire website, and I'm wondering if so many calls to the vBulletin database could be overloading it. Any suggestions on what I could try to fix this issue would be much appreciated!
    Last edited by Buck Satan; Thu 6th Apr '06, 6:38pm.

  • #2
    We need to see the entire error message. Either post the contents of the email you received, or right-click on the error page and go to View/Source. Then copy-n-paste the error message here.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Ahh, I didn't realize you could use View Source to find out what the specific error was. This is the first error I encountered and it sounds like a MySQL issue. Do I need to increase the number of total connections or something? If so, where would I do that?

      Database error in vBulletin :
      mysql_connect(): Can't connect to local MySQL server through socket '/tmp/mysql.sock' (11)
      /home/gbadmin/htdocs/forums/includes/class_core.php on line 279

      Comment


      • #4
        Have you been getting more traffic recently or have you installed any other scripts on the server? phpAdsNew uses a fair number of connections if its being hit a lot with requests.
        Scott MacVicar

        My Blog | Twitter

        Comment


        • #5
          Our traffic hasn't increased significantly, though it's probably about 5-10% higher than last month. We also implemented a new layout across the entire network which slightly increased the number of ads we're displaying. This has never been an issue before, though, and we've been using phpAdsNew for well over a year now.

          Comment


          • #6
            Best thing to do is make phpAdsNew and vBulletin use different mysql usernames, when this error occurs you should be able to login to the server and see which one is stealing all the connections.
            Scott MacVicar

            My Blog | Twitter

            Comment


            • #7
              I am using the same MySQL ID for both applications, and I'm assuming you mean that there is a MySQL connection limit per user ID. Isn't there a way to just increase this limit? Or is creating two usernames a necessity?

              If I go ahead and make two separate usernames, are there any repercussions to changing the username I've used for vBulletin over the past few years?

              Comment


              • #8
                No repurcusions at all, you just need to change the config.php entry.

                Also need to make sure the user you create has permission to access the database the vBulletin files are in.

                You could just increase the global limit but its easier for tracking down problems if a seperate username is used for each application.
                Scott MacVicar

                My Blog | Twitter

                Comment


                • #9
                  I created a second MySQL admin ID and reconfigured phpAdsNew to use that ID instead of the same one vBulletin is using. However, even after making this change, the same "Too many connections" database error continues to occur. Should I try increasing the global limit, like you suggested before? If so, where do I actually make this change?

                  Comment


                  • #10
                    my.cnf on Linux
                    my.ini on Windows

                    the locations vary usually /etc/ or c:/windows/
                    Scott MacVicar

                    My Blog | Twitter

                    Comment


                    • #11
                      Hmm, I've bumped up the max_connections variable in the my.cnf file to 1000, yet I still get the same database errors periodically. Any other suggestions?

                      Comment


                      • #12
                        are you getting this for the forum user or for the phpAdsNew user

                        Also you need to restart MySQL for the new max connectiosn value to work.
                        Scott MacVicar

                        My Blog | Twitter

                        Comment


                        • #13
                          How do I determine which MySQL user is generating the error? I've rebooted the server once and restarted MySQL manually a couple of times as well after changing two other settings (in addition to the max_connections variable). Nothing seems to help, though.

                          Comment

                          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                          Working...
                          X