Announcement

Collapse
No announcement yet.

SQL error 3.5.3 -> 3.5.4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • SQL error 3.5.3 -> 3.5.4

    I'm getting this error when I'm upgrading my board:

    Database error in vBulletin 3.5.4:

    Invalid SQL:

    INSERT INTO vb_upgradelog(script, steptitle, step, startat, perpage, dateline)
    VALUES ('upgrade_354.php', 'Upgrade to vBulletin 3.5.4 Complete!', 0, 0, 0, 1143919771);

    MySQL Error : Duplicate entry '0' for key 1
    Error Number : 1062
    Date : Saturday, April 1st 2006 @ 11:29:31 AM
    Script : http://mysite/install/upgrade_354.php?step=2
    Referrer : http://mysite/install/upgrade_354.php?step=1
    IP Address : x.x.x.x
    Username :
    Classname : vB_Database
    I disabled all my plugins already before trying this. Any ideas why I'm getting this? We're running PHP5.1.2 and MySQL4.x

  • #2
    Hello,

    Did your host change any configuration in the latest days ?

    It might be an increment issue on that table. Well my opinion.

    After backing up your database try to alter the db, if the field is not looking like that already:

    ALTER TABLE `upgradelog` CHANGE `upgradelogid` `upgradelogid` INT( 10 ) UNSIGNED NOT NULL AUTO_INCREMENT;

    Best regards,
    Interdit
    BPowers.com: Eu Web Hosting Solutions
    Shared hosting with Cpanel/Fantastico
    Live Help: http://www.bpowers.com

    Comment


    • #3
      I am the host, so no, nothing was changed. I run the dedicated server myself and I know nothing was changed.

      I did a db backup and I had these issues, so I restored it to 3.5.3 for the time being until I can get this resolved. I'll try that SQL alter and see if that works. Thanks.

      Comment


      • #4
        that worked like a charm!! Thanks so much, I appreciate it!!

        small problem in the adminCP though, some of the menu items aren't showing up. I also had a 'security_x_warning' or something error. Looks like there is a language setting file problem....any ideas??

        I got this error on the upgrade.php
        Warning: Invalid argument supplied for foreach() in /home/forums/public_html/includes/adminfunctions_template.php on line 690
        (Stylevars)
        Warning: Invalid argument supplied for foreach() in /home/forums/public_html/includes/adminfunctions_template.php on line 725
        (CSS) (Replacement Variables)
        Warning: Invalid argument supplied for foreach() in /home/forums/public_html/includes/adminfunctions_template.php on line 780
        (Controls) Done.
        this error happened at step 4 of 5
        Last edited by jdingman; Sat 1 Apr '06, 12:00pm.

        Comment


        • #5
          Try the same for template table: ALTER TABLE `template` ......

          or then try this post: http://www.vbulletin.com/forum/showt...t=1062+mysql+5

          Best regards,
          francois
          BPowers.com: Eu Web Hosting Solutions
          Shared hosting with Cpanel/Fantastico
          Live Help: http://www.bpowers.com

          Comment


          • #6
            that seemed to fix it. I used the code on that LAST post. thanks!!

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X