Announcement

Collapse
No announcement yet.

Moved hosts, now attacment issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Moved hosts, now attacment issues

    Hi peeps

    I have just moved to a new host and now i cannot upload attacments
    and the attachments that are already in place i get this error on a white page

    Code:
    Warning: fopen(): open_basedir restriction in effect. File(/home/sites/bashys-place.com/public_html/attachments/9/3/1190.attach) is not within the allowed path(s): (/home/bashy:/usr/lib/php:/usr/local/lib/php:/tmp) in /attachment.php on line 168
    
    Warning: fopen(/home/sites/bashys-place.com/public_html/attachments/9/3/1190.attach): failed to open stream: Operation not permitted in /attachment.php on line 168
    Any ideas please?

    Regards

    Bashy

  • #2
    You need to chmod the public_html/attachments directory to 777.
    Are you sure you uploaded all the attachment correctly? They have been moved to the filesystem, out of the database it would appear..
    MCSE, MVP, CCIE
    Microsoft Beta Team

    Comment


    • #3
      Hi have already done 777
      Also the files were moved to the file system about 2 months ago...

      Bashy

      Originally posted by Joe Gronlund
      You need to chmod the public_html/attachments directory to 777.
      Are you sure you uploaded all the attachment correctly? They have been moved to the filesystem, out of the database it would appear..

      Comment


      • #4
        I don't believe you can use the file system storage option when you have open_basedir restrictions. You need to move these back to the database, or convince your host to remove these restrictions.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Hi Steve

          I have done what you said, I have moved to the DB all was well, so i moved them back and now all is still OK

          Thanks for ya help!!

          Regards

          Bashy

          Originally posted by Steve Machol
          I don't believe you can use the file system storage option when you have open_basedir restrictions. You need to move these back to the database, or convince your host to remove these restrictions.

          Comment

          Loading...
          Working...
          X