Announcement

Collapse
No announcement yet.

Help! How to Test vBulletin Site Transfer before DNS propagation?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help! How to Test vBulletin Site Transfer before DNS propagation?

    I just moved my vBulletin forums to a new server and had the techs restore the databases. How do I test the restore using the IP address to make sure the forums work before changing dns info?

    My forums are version 3.5 and I also have vBadvanced CMPS installed. I updated the config.php file with the new database info. When accessing via the ip address on the new server I get the CMPS index page just fine and all of the correct data (forum thread highlights, etc) appears.
    I can also get to the admin control panel on the new server. However, when I tried to access the forums I got the following db error:


    Database error in vBulletin 3.5.0:

    Invalid SQL:

    SELECT forum.forumid, lastpost, lastposter, lastthread, lastthreadid, lasticonid, threadcount, replycount
    , forumread.readtime AS forumread
    FROM vb3petsforum AS forum
    LEFT JOIN vb3petsforumread AS forumread ON (forumread.forumid = forum.forumid AND forumread.userid = 3);

    MySQL Error : Table 'tpforums_petsforums.vb3petsforumread' doesn't exist
    Error Number : 1146
    Date : Saturday, March 4th 2006 @ 11:02:21 PM
    Script : http://72.34.40.223/forums/?
    Referrer : http://72.34.40.223/
    IP Address : 24.0.73.103
    Username : xxxxx
    Classname : vb_database

    Am thinking there is another setting I need to change?


    Also, so I could have both the old and new server up while dns propagates, I tried changing the database location on my old server to point to the new server (chg'd db address from localhost to the new ip) but received a database error.

    Can anyone help? I need to get things working asap as I need the forums up again by Sunday afternoon and I still have to upgrade the forums as well. Was trying to get the move done and working properly before doing that.

    The old site is http://www.thepetsforums.com and the new IP is http://72.34.40.223

    Thanks!

    Hmmm, I just realized also that when you access as a guest you don't get the db error because the forums are closed. However, I get it when logged in. As a guest, you can, however, see the right column of the CMPS displayed on the forums page. Why is that?

  • #2
    The error above indicates that the entire database was not moved properly. It is stating that an important table does not exist in your new database.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API

    Comment


    • #3
      Thanks Wayne. I'll check with the tech on the old server.

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X