Announcement

Collapse
No announcement yet.

Letters not showing up as they are suppose to show

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Letters not showing up as they are suppose to show

    First lemme list my config of my server

    Apache 2.0.55
    PHP 5.0.5
    MySQL 4.1.18-r30
    English site

    i have setup a brand new server. The problem is that if i submit a post or create a forum section with characters (like ä for example), it will turn into question marks "?". Let say i create a forum section named Träumend. After i created it will change to Tr?umend. I try different browsers and diff comps and still shows up like that So then i use phpmyadmin and find the field that has Tr?umend. I found it and i manually change it toTräumend. After i save the changes, it shows up fine in the database, but when i go back to the forums, it shows up as Träumend. So i think it has to do with apache and php and mysql. I gotta feeling i didnt setup the right config files maybe?

    So i have no idea whats goin on and im tryin to fix this asap, so i wondering if anyone know how to fix this. Thanks!!!

    UPDATE: Apparently only swedish characters dunt work, others do (like japanese, arabic, etc). Still need resolution
    Last edited by XtAzY; Wed 22 Feb '06, 5:15pm.

  • #2
    oh i am using apache 2.0.55, mysql 4.1.16 and php 5.1.1
    Last edited by XtAzY; Mon 20 Feb '06, 10:28am.

    Comment


    • #3
      Are you using a different language pack?
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        nope im using the same language pack... all i did is downloaded the database from my old server and dumped it into the new server, and transfered all the files to the new one. I didnt mess with any vbsettings upon migration. Although im not sure if the php.ini, my.cnf and apache are configured similiar across the two servers

        Like i have this forum name named: Träumend
        When i check the database, it looks fine. But when i go to my forum, the name shows up like this:Träumend
        Last edited by XtAzY; Mon 20 Feb '06, 12:18pm.

        Comment


        • #5
          What's the URL to a page with an exampe of this?
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            well i turned my forums off but i'll post a screenshot





            its suppose to be Träumend not Träumend....

            if i post Träumend in any thread the "ä" will turn into "?"

            Comment


            • #7
              Have you tried just editing the forum name?
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                yes i did.... it will just turn into Tr?umend

                i gotta feelin its something to do with utf8?...

                Comment


                • #9
                  What is the 'HTML Character Set' setting in your language settings?
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    It is ISO-8859-1

                    Comment


                    • #11
                      What about your browser settings? This is why I wanted to be able to see this directly myself.
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        should i setup a admin account for u to see the forum?

                        Comment


                        • #13
                          the only time it will show correcty is if i change the encodin on my browser to Unicode (UTF-8)....

                          but the thing that puzzle me is why my old server works perfectly fine while the new server does not. I still have a feeling that i misconfigured my server rather than the forum itself

                          Comment


                          • #14
                            i just upgraded to v3.5.4 and i still have that same error... but i do know the problem is not from the forum.... its gotta be the way i configured my server because if my old host works and the servers here at vb.com works, then its gotta be my config errors.... im just wondering if someone mind and take a look and see if i configure it correctly...

                            Comment


                            • #15
                              updated first post

                              ok so the only types of characters that not working correctly are the swedish characters (both when submiting posts and viewing swedish characters). Japanese, arabic, and all other language works and displays fine.

                              My mysql collation for my database is always set at latin1_swedish_ci

                              can anyone advise me on how to fix this?

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X