Announcement

Collapse
No announcement yet.

User Manager - HTTP 406 Not Acceptable

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • User Manager - HTTP 406 Not Acceptable

    I am getting a HTTP 406 Not Acceptable error when I try to save a user's settings with the following signature.


    [center][font="Arial Black"][color="Blue"][size="4"]Big & Rich rock my socks :)[/size][/color][/font]
    [IMG]http://img303.imageshack.us/img303/8075/teyla8dv.jpg[/IMG]
    [IMG]http://img246.imageshack.us/img246/3112/llamel7sm.jpg[/IMG][color="Teal"]~Llamel 4 Lyfe~[/color][/center]


    If I change the IMG URL slightly by changing the domain from "imageshack.us" to "pimageshack.us" as shown below it saves successfully. What checking is done on signatures that would be causing this?


    [center][font="Arial Black"][color="Blue"][size="4"]Big & Rich rock my socks :)[/size][/color][/font]
    [IMG]http://img303.imageshack.us/img303/8075/teyla8dv.jpg[/IMG]
    [IMG]http://img246.imageshack.us/img246/3112/llamel7sm.jpg[/IMG][color="Teal"]~Llamel 4 Lyfe~[/color][/center]


    Thanks,
    -Kevin

  • #2
    Apparently it was my hosting provider's mod_security Apache module filtering the HTTP post request. I added the following line to my .htaccess file and it fixed the problem.

    Code:
     
    SecFilterEngine Off
    -Kevin

    Comment


    • #3
      Where in the .htaccess file does it go? I'm having this problem too.

      Comment


      • #4
        Put that line anywhere.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Well, I did that, and now I get an Internal Server Error.

          So I took it out and then the site loaded fine.

          Is there any way to fix this?

          My error occurs when someone tries to register (after filling in the date of birth and clicking go) is when it happens, so obviously we're desperate to get this fixed as soon as possible. No one can register right now.
          Last edited by swepics; Fri 14th Apr '06, 3:21pm.

          Comment


          • #6
            What are the contents of your .htaccess file when you add that line?

            Note: This was not my recommendation so I cannot vouch for it as a solution.

            My suggestion is that you contact host and ask them to uninstall mod_security. They have implemented this in such a way that it is breaking vB.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              # -FrontPage-

              IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*

              <Limit GET POST>
              #The next line modified by DenyIP
              order allow,deny
              #The next line modified by DenyIP
              #deny from all
              allow from all
              </Limit>
              <Limit PUT DELETE>
              order deny,allow
              deny from all
              </Limit>
              AuthName www.starwarsepics.com
              AuthUserFile /home/swpcs/public_htm/_vti_pvt/service.pwd
              AuthGroupFile /home/swpcs/public_htm/_vti_pvt/service.grp


              <Files 403.shtml>
              order allow,deny
              allow from all
              </Files>

              deny from 86.57.48.69
              deny from 195.225.176.115
              deny from 148.244.150.
              deny from 69.132.78.235
              deny from 71.71.172.138
              SecFilterEngine Off
              But I took that last one out. This issue has turned up before with them (they make the whole site hang just when someone posts the word "curl") and they have already told me they will not remove mod_security.

              Comment


              • #8
                Try this:

                http://www.vbulletin.com/forum/showthread.php?t=167121
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Thanks, I will. Will this code not give the Internal Server Error I was getting before?

                  Comment


                  • #10
                    Internal Server Error again.


                    Is there anything else I can do to make this work? We disabled the age requirement for registering (skipping the page that spits out the error) but we really don't want anyone younger than 13 to join. And today a 12-year old joined.

                    Comment


                    • #11
                      To troubleshoot this, remove any hacks and disable your plugins, then see if you still have this problem.

                      If so, reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server.

                      Next, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        As Steve posted above, you should really contact your host and ask him to uninstall/disable mod_security.
                        Best Regards
                        Colin Frei

                        Please don't contact me per PM.

                        Comment


                        • #13
                          I have done all this and it does work, however, it works randomly in all styles. It's not something I can really test and say 100% yes or no.

                          Colin, I did ask them the first time a problem came up. They will not remove it. And they haven't responded to my post of April 25 asking for help.

                          Comment

                          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                          Working...
                          X