Announcement

Collapse
No announcement yet.

MySQL 4.1.x -> MySQL 5.0.18

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MySQL 4.1.x -> MySQL 5.0.18

    I'm wondering if anyone's done an upgrade from MySQL 4.1 to 5.0.18...

    I tried it tonight... the ugprade went fine (did it on a test box) and proceeded to try to move a site over and vBulletin puked all over itself after importing the DB into MySQL 5

    Now its possible I missed something because I've been doing OS configuration and setup for about 12 hours.

    Steps I took...

    Install dev box, Install latest PHP 4, latest Apache 1.3 and latest MySQL5.

    mysqldump forum from production server

    import mysqldump on dev box

    test forum...

    forum displays, forum shows threads... but when you pull up a threadview vBulletin vomits. SQL Error 1xxx about customavatar.

    Now I have no hacks installed, its a stock vBulletin forum.

    I disabled STRICT mode.

    I set the force sql to true.

    Still didnt work.

    I'm willing to provide any info needed...

  • #2
    *sigh*

    I guess either I didn't supply enough information or we just dont answer the more difficult questions here...

    Comment


    • #3
      Well, I for one don't understand what you are asking so you miught want to clarify this.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        I've just done it

        Although I'm running under Windows Server 2003, I've upgraded MySQL to v5.0.18, from v4.1.16.

        I can log onto the Admin control panel, but I'm getting these errors everytime a page is loaded:

        Database error in vBulletin 3.5.3:

        Invalid SQL:

        UPDATE session
        SET lastactivity = 1138901485, location = '/forums/admincp/index.php', loggedin = 2, inforum = 0, inthread = 0, incalendar = 0, badlocation = 0, useragent = 'Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; InfoPath.1; .NET CLR 2.0.50727)', bypass = 0
        WHERE sessionhash = '72f9126cf527ea6a3b54f5e07308945d';

        MySQL Error : Data too long for column 'useragent' at row 1 Error Number : 1406
        Date : Thursday, February 2nd 2006 @ 11:31:25 AM
        Script : http://<ip address>/forums/admincp/index.php
        Referrer : http://<ip address>/forums/admincp/index.php?do=head
        IP Address : <ip address>
        Username : <username>
        Classname : vB_Database

        Any ideas?

        Comment


        • #5
          Originally posted by Steve Machol
          Well, I for one don't understand what you are asking so you miught want to clarify this.
          Last night I moved my forum from one box to another.

          The current box is: MySQL 4.1.x/PHP 4.x/Apache 1.3.x

          The new box is: MySQL 5.0.x/PHP 4.x/Apache 1.3.x

          The steps I took:

          1. mysqldump'ed the database from current box
          2. imported the mysqldump into the new box
          3. copied over the files
          4. loaded the website into my browser
          5. it looked ok until I tried to read the threads... phrases werent working all kinds of misc issues.

          So my question is why would a mysqldump imported into MySQL 5 not work?

          Strict mode is disabled...

          *scratches head*

          Comment


          • #6
            MySQL Error : Data too long for column 'useragent' at row 1 Error Number : 1406

            Look at the session table. What table type is it and what are the settings for the 'useragent' field?
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Originally posted by runuo.com
              Last night I moved my forum from one box to another.

              The current box is: MySQL 4.1.x/PHP 4.x/Apache 1.3.x

              The new box is: MySQL 5.0.x/PHP 4.x/Apache 1.3.x

              The steps I took:

              1. mysqldump'ed the database from current box
              2. imported the mysqldump into the new box
              3. copied over the files
              4. loaded the website into my browser
              5. it looked ok until I tried to read the threads... phrases werent working all kinds of misc issues.

              So my question is why would a mysqldump imported into MySQL 5 not work?

              Strict mode is disabled...

              *scratches head*
              Let me also clarify that I have done this numerous times with no issue... MySQL 5 is the only change.

              Comment


              • #8
                Originally posted by Steve Machol
                MySQL Error : Data too long for column 'useragent' at row 1 Error Number : 1406

                Look at the session table. What table type is it and what are the settings for the 'useragent' field?
                Session table type is "Memory" and the settings for useragent field is varchar(100).

                Comment


                • #9
                  Mine is HEAP and char(100). Not sure if this make a difference.

                  My guess is the mysqldump for MySQL 4.1 is not quite compatible with MySQL 5, otherwise this would have worked without a hitch. You might want to check the MySQL home page for any info regarding this:

                  http://www.mysql.com/
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    Originally posted by Lexical
                    Session table type is "Memory" and the settings for useragent field is varchar(100).
                    Mysql 5 defaults to strict mode=on which will generate errors like the one you have when data being inserted/updated is larger than the field definition. If you turn strict mode to OFF in your my.ini file this should go back to the "old" behaviour where it will fit as much data in the field and discard the rest.

                    In your my.ini (this is from a windows box), in the server section, find this line...

                    # Set the SQL mode to strict
                    sql-mode="STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION"

                    and change it to...

                    # Set the SQL mode to strict
                    #sql-mode="STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION"

                    Then restart mysql...
                    Last edited by dapinard; Thu 2nd Feb '06, 9:26am.

                    Comment


                    • #11
                      Originally posted by Steve Machol
                      My guess is the mysqldump for MySQL 4.1 is not quite compatible with MySQL 5, otherwise this would have worked without a hitch. You might want to check the MySQL home page for any info regarding this:

                      http://www.mysql.com/
                      Well if I had no idea, I would guess that also, however I moved over 9 sites in total which all require MySQL and they all worked fine. The only site that had issues was a vBulletin forum.

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X