Announcement

Collapse
No announcement yet.

Confirmation Emails not going out

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Confirmation Emails not going out

    I have had a number of new user report that after registering they are not receiving confirmation emails, and thus cannot complete the registration process.. I just registered a new name myself on my forum and I did not get an email either.. what should I look into???

    thanks!


    Serg

  • #2
    In the Vbulletin Control Panel try the following:

    Maintenance > Diagnostics >

    Under email use your problem email address and submit. You may get an error that you can forward to your host.

    I had the same problem and that helped. The provider was able to fix the server. I still have a similar problem with AOL though.

    Comment


    • #3
      Just tried it.. .no luck...

      Comment


      • #4
        Make sure you have a valid webmaster's email address in your Admin CP settings and that there is only one address. Then try this:

        Admin CP -> vBulletin Options -> Email Options -> Enable "-f" Parameter -> Yes

        Then try the vB email functions.

        If it still doesn't work, then this is either a server and/or mailbox issue.

        vB uses PHP's mail() function for all its email and uses the SMTP server specified in php.ini. If PHP and the mail server are configured correctly then email will work.

        Since some email is working, you will need to view the mail logs on the server to see what happened to those emails that don't work. Once vB sends it to PHP it's in the hands of the server. If you are on a shared server you may need to ask your host to look through the logs for you.

        For what it's worth I get a lot of bounced emails from people who's mail boxes are full, 'unavailable' or over quota. This is a particular problem with hotmail and yahoo accounts. Unless you are on a dedicated server and can set where these bounce messages go, you will never see them. The mail logs will have a record of these though.

        Another thing to keep in mind is that many ISPs and mail clients are putting in very aggressive spam filters. It's possible these emails are being placed into a spam folder or are being filtered.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          hmm.. well before I did that I tried my Yahoo account and that email came through just fine. I did what you suggested Steve and tried sending the email to my address that did not receive it.. I immediately got an error message on the account of the forum in question stating that:

          unrouteable mail domain "******.com"

          But I can send emails to that domain just fine....

          Comment


          • #6
            unrouteable mail domain "******.com"

            This is a server configuration problem. Read this:

            http://www.vbulletin.com/forum/showp...6&postcount=20

            Also with Yahoo hosting, you need to make sure the Webmaster's email address in the vBulletin Options is using the same domain name as your forums. Otherwise email won't work correctly. (This is a problem specific to Yahoo.)
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              I think I need to expand on what I am trying to say, I did not explain it well the first time.

              I have an email address, my standard email through Earthlink. Then I have 2 address that go to the above, one from each of my forums. Forums run at same host, but 2 different servers. The email address I can't get a confirmation on from my Gadget forum, I get emails just fine from my Land Rover forum. This address is my Land Rover forum contact address. So for some reasong my Gadget forum can't send emails to the address my Land Rover forum can.. odd.. anything else I need to check??

              Serg

              Comment


              • #8
                Please read post #6.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Ok... I did look.. and I have Cpanel.. but I have no idea what "WHM" means... I looked all around my Cpanel and I could not find it.. can you give me a better idea of what exactly I am looking for?

                  Thanks!

                  Comment


                  • #10
                    Unless you have a dedicated server with complete root access, this is a problem that can only be fixed by your host. You need to ask them to resolve this.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Yeah I emailed them.. thank you for your help... again...

                      Comment


                      • #12
                        Steve, I am awaiting a call back from my host.. in the meantime I disabled the F parameter... when I had it enabled the emails bounced back to me, now that I disabled it, those emails are not going out... here's the real frustratig part:

                        On this forum I send the diagnostic email to ********@landroversonly.com which is my email address on my other forum.. nothing comes through if "F" is turned off, and it shows up bounced in my inbox if I turn "F" on..

                        Then from the same forum I can send email to my addresses on the same outlook account as the landrvoersonly email, and also on my yahoo account... and those all come in fine... aagghhh However some people who have Yahoo won't get this email... man this is weird.. still think it's a server issue? Should I have that F parameter on or off???

                        How about this.. on the forum I am having issues with I see this when I send diagnostic email:

                        SMTP:localhostsendmail_from:Nonesendmail_path:/usr/sbin/sendmail -t -i

                        On the Forum that works it says [email protected] instead of None, is there a way to change it????

                        Comment


                        • #13
                          1. Leave '-f' on.

                          2. What does this mean?

                          On the Forum that works it says [email protected] instead of None, is there a way to change it????
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #14
                            Sorry Steve.. I know you're just trying to help. That is the message I get after I send the Diagnostic email from my troubled forum. My question is:

                            Should the section that reads "sendmail_from:None" be something other than "none"? On my other forum it is showing as "sendmail_from:[email protected]:

                            Comment


                            • #15
                              Are you on a Windows server or a *Nix one?
                              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                              Change CKEditor Colors to Match Style (for 4.1.4 and above)

                              Steve Machol Photography


                              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                              Comment

                              Loading...
                              Working...
                              X