Announcement

Collapse
No announcement yet.

Template page stalls and not save

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Template page stalls and not save

    Version 3.5.2

    After adding new codes in the search template, I click save and the admin panel stalls forever and not save.
    I tried 'Save and Reload' and it does not change.

    But if I change the new addition of the code, it saves properly. The new code contains the Yahoo ad which is in Javascript.

    What could be the problem.

  • #2
    Try saving it in a different browser.
    Best Regards
    Colin Frei

    Please don't contact me per PM.

    Comment


    • #3
      Hello Colin. Both Firefox and IE stalls when trying to save the page. Any other method I should give a try? TIA.

      Code:
      <tr>
          <td height="60" class="alt1">
              <img src="$stylevar[imgdir_statusicon]/image.gif" alt="" border="" /></td>
              <td height="60" align="center" class="alt2">&nbsp;</td>
          <td height="60" align="center" class="alt1">
              <div>
          Ads in javascript
              </div>        
          </td>
          <td height="60" align="center" class="alt2 smallfont">Links</td>
              <td height="60" align="center" class="alt1"></td>
              <td height="60" align="center" class="alt2"></td>
               <if condition="$show['inlinemod']"><td height="60" align="center" class="alt1"></td>
               </if>
      </tr>
      </if>
      Originally posted by Colin F
      Try saving it in a different browser.

      Comment


      • #4
        This is a server time and/or memory limit. To temporarily up your limits edit your includes/config.php file and add these lines right under the <?php line:

        ini_set('memory_limit', 32 * 1024 * 1024);
        ini_set("max_execution_time", "240");
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Hello Steve, the code was added right below the php line, but the page continues to load/stall.

          Originally posted by Steve Machol
          This is a server time and/or memory limit. To temporarily up your limits edit your includes/config.php file and add these lines right under the <?php line:

          ini_set('memory_limit', 32 * 1024 * 1024);
          ini_set("max_execution_time", "240");

          Comment


          • #6
            This is indeed an issue. Many in our network (almost 50 communities) report this same problem on occasion. And one of my server admin just came to me because one of our servers' load was high. The culprit?

            POST /admincp/template.php

            The process had been running a LONG time.

            More people having the same issue: http://www.vbulletin.com/forum/showt...t=template.php
            Last edited by thegunowner149; Fri 20th Jan '06, 4:14am.

            Comment


            • #7
              This happened to me as well. I added the code Steve mentioned but it didn't help.

              I think it has something to do with the code you are trying to enter. I was modifing the memberinfo. I made changes and it would stall. I would copy back the original html and it would save fine.

              Comment


              • #8
                What version of php and mysql are you guys running?

                PHP 5.0.5 and mysql 4.1.12 here.

                Comment


                • #9
                  I've asked the Devs to check out this thread.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    Code:
                    <tr>
                    <td height="60" class="alt1">
                    <img src="$stylevar[imgdir_statusicon]/image.gif" alt="" border="" /></td>
                    <td height="60" align="center" class="alt2">&nbsp;</td>
                    <td height="60" align="center" class="alt1">
                    <div>
                    Ads in javascript
                    </div> 
                    </td>
                    <td height="60" align="center" class="alt2 smallfont">Links</td>
                    <td height="60" align="center" class="alt1"></td>
                    <td height="60" align="center" class="alt2"></td>
                    <if condition="$show['inlinemod']"><td height="60" align="center" class="alt1"></td>
                    </if>
                    </tr>
                    </if>
                    You have an extra </if> which is causing the template processor to choke

                    Comment


                    • #11
                      Zachery, that seemed to have fixed the problem.
                      Good luck to those that are having a similar problem.

                      Comment


                      • #12
                        Some of these issues may be caused by malformed conditionals or other coding errors, but instead of spitting out the error as in the past, it constantly hangs and tries to save.

                        Comment


                        • #13
                          Open
                          includes/adminfunctions_template.php

                          Code:
                          -        $if_end_location = strpos($template_cond, $if_end_lookfor, $condition_end + 3); // location of conditional terminator
                          +        $if_end_location = strpos($template_cond, $if_end_lookfor, $condition_start + 3); // location of conditional terminator
                          Scott MacVicar

                          My Blog | Twitter

                          Comment

                          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                          Working...
                          X