Announcement

Collapse
No announcement yet.

Can't upgrade or access forums

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't upgrade or access forums

    I did my upload to go from 3.5.2 to 3.5.3 and when I get to the step to open my browser and point it to the upgrade.php, I get a message saying I don't have permissions to access it.

    Please help.

    Thanx,

    John

  • #2
    Can you post the exact wording of the message?
    When pointing your browser to upgrade.php you should actually see a screen where you need to input your customer number.
    Best Regards
    Colin Frei

    Please don't contact me per PM.

    Comment


    • #3
      I know I should get that screen as I always have before. Attached is the error message I am getting.

      I did it a little differently this time though. Instead of replacing all the files in Forums, I renamed Forums to Xforums so I would have a backup in case something went wrong. I then renamed the upload folder to forums. Is this a no-no? Could and why would it cause this problem?
      Attached Files

      Comment


      • #4
        The renaming shouldn't be a problem.
        What you're getting is a server side forbidden message.
        Check if your files are CHMODed to 644, and if they are, I'd advise asking your host for help.
        Best Regards
        Colin Frei

        Please don't contact me per PM.

        Comment


        • #5
          Originally posted by Colin F
          The renaming shouldn't be a problem.
          What you're getting is a server side forbidden message.
          Check if your files are CHMODed to 644, and if they are, I'd advise asking your host for help.
          Forgive me but I don't know what CHMODed is or how to check for it.

          I am using Vicom FTP Client on a Mac running OS/X 10.4.4 if that's any help.

          Thanx for your help but I think I need a wee bit more.

          Comment


          • #6
            CHMOD is the Unix permissions editor, the number mearly represents user, group and global permissions I think. In order to change permissions you need to right click (in the Macs case I think it is Ctrl click) the file in question from within the FTP program you use and look for something that looks like properties or CHMOD properties and then change them to 644 and try again.

            I hope that helps a bit, most FTP programs work the same way. Alternativly you could always do it via SSH if you have that enabled.

            Comment


            • #7
              I was able to find where to change them to 644 but they won't stay at that. They keep reverting to 755.

              I have asked my web-host to look into this. If I ever get it figured out I'll let ya'll know in case someone else runs into this.

              Many thanx to everyone for the suggestions.

              Comment


              • #8
                Originally posted by LCPGUY
                I did my upload to go from 3.5.2 to 3.5.3 and when I get to the step to open my browser and point it to the upgrade.php, I get a message saying I don't have permissions to access it.

                Please help.

                Thanx,

                John
                I just upgraded one of my clients vBulletins from 3.5 to 3.5.3 and I also get this Forbidden 403 error for the entire account. Even folders on the server that are not relating to vBulletin! All I did was unzip the upgrade, upload it via ftp to the clients public_html dir and whammo - this error.

                Permissions are 644 - chown are correct too. VERY weird!

                Any ideas?

                Comment


                • #9
                  This is most likely due to mod_security. See this thread:

                  http://www.vbulletin.com/forum/showthread.php?t=167121
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    Originally posted by Steve Machol
                    This is most likely due to mod_security. See this thread:

                    http://www.vbulletin.com/forum/showthread.php?t=167121
                    Thanks for the reply - wasnt that which caused the problem - turned out that I fluffed up for owner permissions of public_html.

                    Instead of it being username.nobody I had it as username.username like the files! Doh!

                    Thanks anyway!

                    James

                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X