Announcement

Collapse
No announcement yet.

How do I use CSS for usergroup markups?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • How do I use CSS for usergroup markups?

    I'd like to get my code as up to date as possible. Right now, for example, I make the admin group's markup bold and orange by putting simple HTML tags in:

    Code:
    <font color="orange"><b>
    And then just closing them. This doesn't work quite right in anything but IE - Firefox doesn't like it, it makes the link underline white.

    I tried adding the following to the main CSS:
    Code:
    .adminmarkup
    {
    color:orange;
    font-weight: bold;
    }
    And then using:
    Code:
    opening:
    <div style="adminmarkup"> 
    closing:
    </div>
    For the username markup. It didn't even come close to working properly, it added some crazy line breaks and killed the layout of my site entirely. What's the proper way to do this so that the page looks the same cross platform?

    Thanks in advance.

  • #2
    <span style="adminmarkup"> </span>

    Comment


    • #3
      Thanks, one small problem.

      This only seems to work for one usergroup.

      I have the following classes defined:

      Code:
      .adminmarkup
      {
      color:orange;
      font-weight: bold;
      Text-Decoration: Underline;
      }
      .moderator
      {
      color:#2886B6;
      font-weight: bold;
      Text-Decoration: Underline;
      }
      .contmarkup
      {
      font-weight: bold;
      Text-Decoration: Underline;
      }
      However only adminmarkup works - moderator and contmarkup don't have any effect at all. What am I missing?

      Comment


      • #4
        Aah, got it figured out. "span class=" does it, "span style=" does not.

        Comment


        • #5
          Set the markup for each usergroup with appropriate style

          Admin group to <span class="adminmarkup"> </span>

          Moderator group to <span class="moderator"> </span>

          etc.

          Comment


          • #6
            Gawd, I can't believe I typed style. I gotta get more sleep :roll:

            Comment


            • #7
              If it's any consolation to you, I typed class in the admin markup, then typed style about 5 times in the wrong spot and sat scratching my head wondering why it wasn't workingn.

              I'm with you on the whole needing sleep thing. Once you develop a serious vB modding habit, it's difficult to work sleep into your routine.

              Comment


              • #8
                Yep, it's an addiction alright. Can think of worse things to be addicted to though.

                Comment


                • #9
                  I'm having the same problem. I'd like the Username HTML Markup to appear the same in both IE and Firefox, but i don't understand how to make it happen.

                  Am i suppose to add this ... <span class="adminmarkup"> </span> ... in the same field(s) where ... <font color="000000"> </font> is located ... in the Username HTML Markup ... or does it go in a file somewhere?

                  If you don't mind, can you give me an exact copy / example of what i should be doing.

                  Thank you.

                  LTW

                  Comment


                  • #10
                    Originally posted by LTW View Post
                    I'm having the same problem. I'd like the Username HTML Markup to appear the same in both IE and Firefox, but i don't understand how to make it happen.

                    Am i suppose to add this ... <span class="adminmarkup"> </span> ... in the same field(s) where ... <font color="000000"> </font> is located ... in the Username HTML Markup ... or does it go in a file somewhere?

                    If you don't mind, can you give me an exact copy / example of what i should be doing.

                    Thank you.

                    LTW
                    Please someone ... help me. I apologize if i should have started a new thread.

                    LTW

                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X