Announcement

Collapse
No announcement yet.

Email Options Don't Show SMTP Options

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Email Options Don't Show SMTP Options

    On an install that has only just gotten going, the email options in the Admin CP, does not show the areas it should for setting the email server, and other SMTP related options. It only shows the following:
    • Enable Email features?
    • Allow Users to Email Other Members
    • Use Secure Email Sending

    • Email Flood Check


    This is down quite a few options from the other forums that I have setup. The SMTP server in question is correctly called out in /includes/mail.php but not entered anywhere in the control panel as there is no place to enter it.

    Diagnostics reveal the following:
    SMTP:localhostsendmail_from:Nonesendmail_path:None

    • Not sure where "localhost" is being set, I am guessing in the PHP.INI, which I was able to override once on the same hosting provider by using one of the vBulletin includes.
    • How do I get to the correct Email options panel?
    • Thanks and Happy New Year!
    • Chris Geiser

  • #2
    In 3.5.2 you can select the SMTP server.

    Admin Control Panel > vBulletin Options > vBulletin Options > Email Options

    Comment


    • #3
      Upgraded to 3.5.2

      Now for some reason I am getting the following error in the diagnostics:

      Warning: Unexpected response from SMTP server during TO address transmission in \includes\class_mail.php on line 519

      Anyone have any clues on this?

      Comment


      • #4
        No sorry, I have very little experience with mail issues.

        Make sure you have set the right host, user/pass and port in the global vbulletin options for smtp, and have turned on to use smtp as mail processor.

        Comment


        • #5
          Line 519:
          trigger_error($msg, E_USER_WARNING);

          This would appear to be a problem with either the server, your SMTP settings or the email address you are sending to.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X