Announcement

Collapse
No announcement yet.

PayPal Subscriptions not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • NexVision
    replied
    Thats is the solution right there worked for me to.

    Leave a comment:


  • ncangler
    replied
    I'm glad that worked for you too. It took me awhile to figure that one out, but thanks to Conqsoft it works perfectly.
    Originally posted by conneva
    Before finding this thread I had narrowed the problem down to something to do with recurring subscriptions. I also had subscriptions that had a length of 365 days.

    Changing the subscription length to 1 Year from 365 Days corrected the issue for me.

    Thanks!

    Mark

    Leave a comment:


  • conneva
    replied
    Paypal "Invalid Link" error message on recurring subscriptions w/ length of 365 Days

    Before finding this thread I had narrowed the problem down to something to do with recurring subscriptions. I also had subscriptions that had a length of 365 days.

    Changing the subscription length to 1 Year from 365 Days corrected the issue for me.

    Thanks!

    Mark

    Originally posted by ncangler
    Thanks to Conqsoft I finally figured out that the recurring payments selection was causing my PayPal problem. And specifically I had my subscription setup for 365 days (don't ask me why!). Per Conqsoft's suggestion I changed it to 1 year and it works perfectly. Thank you guys for helping me through this!

    Leave a comment:


  • wacnstac
    replied
    Glad you were able to get this fixed. It helps us all.

    Leave a comment:


  • ncangler
    replied
    Thanks to Conqsoft!

    Thanks to Conqsoft I finally figured out that the recurring payments selection was causing my PayPal problem. And specifically I had my subscription setup for 365 days (don't ask me why!). Per Conqsoft's suggestion I changed it to 1 year and it works perfectly. Thank you guys for helping me through this!

    Leave a comment:


  • ncangler
    replied
    BINGO! It is a problem with the Recurring payments. I turned that off and the process went right through! You ROCK Conqsoft. Thank you. My subscriptions are annual and I think I saw somewhere that PayPal doesn't handle subscriptions for that long a period. So I'll have to figure a way to handle resubscribing folks by the time that rolls around for most of my members. But I'm back in business thanks to you!

    Leave a comment:


  • ncangler
    replied
    Yes the Primary PayPal email address was set. but I'm going to try to turn off recurring and see what happens. Thanks.

    Originally posted by conqsoft
    It looks like you have it set as recurring? If so, did you set the Primary PayPal e-mail address when you set up the PayPal API entry?

    Leave a comment:


  • ncangler
    replied
    Thanks Conqsoft for helping me with this. I will check that out with a developer and see what is going on. BTW none of the Paid Subscription templates have been altered at all in 3.5.2. Thanks again.

    Leave a comment:


  • conqsoft
    replied
    It looks like you have it set as recurring? If so, did you set the Primary PayPal e-mail address when you set up the PayPal API entry?
    Paypal Primary Account Email
    Your PayPal primary account email that corresponds to the address above, this is required for recurring susbcription verification.

    Leave a comment:


  • ncangler
    replied
    That's right. When you click "Order Using PayPal" I get the response in the attached .jpg. It is a PayPal generated error from: https://www.paypal.com/cgi-bin/webscr
    Attached Files

    Leave a comment:


  • conqsoft
    replied
    Ok, I registered on your site and tried it. This has nothing to do with IPN, since that is used after the payment is sucessful.

    When clicking the button to purchase your subscription, I get:
    Error Detected

    --------------------------------------------------------------------------------
    The link you have used to enter the PayPal system is invalid. Please review the link and try again.
    Here's the code behind your Pay with PayPal button, as generated by vBulletin. A dev can look at it and see if anything looks wrong. You may want to make sure your "subscription_payment_paypal" template is reverted.

    HTML Code:
    			<form action="https://www.paypal.com/cgi-bin/webscr" method="post">
    	<fieldset class="fieldset">
    		<legend>Order Using PayPal</legend>
    		<div style="padding:1px">
    			<div style="margin-bottom:1px">To pay for your subscription using <a href="http://www.paypal.com" target="_blank">PayPal</a> click the button below and follow the onscreen instructions.</div>
    			<div>
    				
    <input type="hidden" name="cmd" value="_xclick-subscriptions" />
    
    <input type="hidden" name="business" value="[email removed]" />
    <input type="hidden" name="item_name" value="Captain's Club Member Subscription" />
    <input type="hidden" name="item_number" value="10981e44ff8676ab3f9391905a6efb2d" />
    <input type="hidden" name="currency_code" value="USD" />
    
    <input type="hidden" name="a3" value="25.00" />
    <input type="hidden" name="p3" value="365">
    <input type="hidden" name="t3" value="D">
    <input type="hidden" name="src" value="1">
    <input type="hidden" name="sra" value="1">
    
    <input type="hidden" name="no_shipping" value="1" />
    <input type="hidden" name="shipping" value="0.00" />
    <input type="hidden" name="return" value="http://www.ncangler.com/forums/index.php" />
    <input type="hidden" name="cancel_return" value="http://www.ncangler.com/forums/index.php" />
    <input type="hidden" name="notify_url" value="http://www.ncangler.com/forums/payment_gateway.php?method=paypal" />
    <input type="hidden" name="custom" value="ConqSoft" />
    <input type="hidden" name="no_note" value="1" />
    
    <input type="hidden" name="tax" value="0.00" />
    
    				<input type="submit" class="button" style="font-weight:normal" value="Order Using PayPal" />
    			</div>
    		</div>
    	</fieldset>
    </form>
    Last edited by conqsoft; Thu 29 Dec '05, 11:26am.

    Leave a comment:


  • conqsoft
    replied
    What do you mean "The link to PayPal still isn't made"? When you go to your subscription, and click the Pay with PayPal button?

    Leave a comment:


  • ncangler
    replied
    Man this is frustrating. I have already removed the IPN address (left IPN checked as on), I've confirmed that cURL is compiled and working and I get the same results with cURL and Streams (PASS). But the link to PayPal still isn't made and I just get a page with that error message. I don't know where to go from here. ?

    Leave a comment:


  • conqsoft
    replied
    That URL isn't supposed to return anything except a blank screen. (Just like mine: http://www.fireblades.org/forums/pay...?method=paypal) Remove your IPN URL from your PayPal account. Leave it blank. It's not needed.

    And, make sure cURL is correctly configured at Zachery said.

    From mine:
    Paypal
    cURL Pass
    Streams Pass

    PayPal payments work fine with vBulletin.

    Leave a comment:


  • ncangler
    replied
    I contacted PayPal about the error message above and their response was
    The page your provided came up blank when I went to it. I suspect the error message you are getting comes from the script you are calling and I would begin to look there for starters.
    Apparently there is a problem between the vbulletin payment processor and the connection with PayPal. Any other ideas? Thanks guys for your help. If I can't get PayPal working I may have to try another processor.

    The error again is
    Error Detected - The link you have used to enter the PayPal system is invalid. Please review the link and try again.

    Leave a comment:

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X