Announcement

Collapse
No announcement yet.

Cannot make changes to styles...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot make changes to styles...

    I upgraded my version of PHP last nite, for security reasons. It was not a major upgrade, just security fixes.

    Now, whenever I try to make changes to a style in 'Common Templates', when I hit 'Save' it takes me back to an AdminCP login (and doesn't display my login). It only does it in that single frame.

    I know it has something to do with PHP, however I have checked to make sure my new php.ini and the old one match, and they do. Still, nothing.

    I've checked several other AdminCP features, and they seem to work...


    Any ideas?

  • #2
    Also tried adding the .htaccess file, no change.

    Comment


    • #3
      What PHP version did you upgrade from, and what is your new version?
      Want to take your board beyond the standard vBulletin features?
      Visit the official Member to Member support site for vBulletin Modifications: www.vbulletin.org

      Comment


      • #4
        Originally posted by MarcoH64
        What PHP version did you upgrade from, and what is your new version?
        4.3.9 to 4.4.1.

        Comment


        • #5
          Enable phpinfo in the Admin CP, then provide the URL to your forums. This may help us troubleshoot this problem.

          Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Public phpinfo() Display Enabled
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Originally posted by Steve Machol
            Enable phpinfo in the Admin CP, then provide the URL to your forums. This may help us troubleshoot this problem.

            Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Public phpinfo() Display Enabled
            Done.
            Last edited by norespect; Mon 26 Dec '05, 10:54pm.

            Comment


            • #7
              This may be the issue here:

              PHP Version 4.4.1 with Hardening-Patch 0.4.8

              I have seen some funny issues with this patch.

              This may also be a server time and/or memory limit. To temporarily up your limits edit your includes/config.php file and add these lines right under the <?php line:

              ini_set('memory_limit', 32 * 1024 * 1024);
              ini_set("max_execution_time", "240");
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                Originally posted by Steve Machol
                This may be the issue here:

                PHP Version 4.4.1 with Hardening-Patch 0.4.8

                I have seen some funny issues with this patch.

                This may also be a server time and/or memory limit. To temporarily up your limits edit your includes/config.php file and add these lines right under the <?php line:

                ini_set('memory_limit', 32 * 1024 * 1024);
                ini_set("max_execution_time", "240");
                Same thing.

                I will try and find a 4.4.1 build, without the patch...but I tried in the first place with no avail.

                Comment


                • #9
                  Got rid of the hardening patch, and it works fine.

                  Thanks.

                  Comment


                  • #10
                    You're welcome.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Originally posted by Steve Machol
                      This may be the issue here:

                      PHP Version 4.4.1 with Hardening-Patch 0.4.8

                      I have seen some funny issues with this patch.

                      This may also be a server time and/or memory limit. To temporarily up your limits edit your includes/config.php file and add these lines right under the <?php line:

                      ini_set('memory_limit', 32 * 1024 * 1024);
                      ini_set("max_execution_time", "240");
                      Hey Steve, just an FYI for you and the team on the hardening patch, cause I'm running it and had problems with the admincp updating ALL options and updating styles on the main ALL styles options pages.

                      The patch is greedy about GPC vars and I've come up with ini settings for the patch that work well with my cms, vB, phpmyadmin, etc. These numbers are somwhat arbitrary, but most of them I came up with based on my own needs.

                      Anyway, just figured I'd share with you guys so you might be able to unofficially recommend some php config changes for this patch:

                      Code:
                      ;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
                      ; Hardened PHP Patch settings ;
                      ;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
                      
                      ; We set these higher than default so we can work
                      ; well with our cms and phpmyadmin
                      
                      hphp.get.max_array_depth		= 100
                      hphp.post.max_array_depth		= 100
                      hphp.cookie.max_array_depth		= 100
                      hphp.request.max_array_depth		= 300
                      
                      hphp.get.max_array_index_length		= 256
                      hphp.post.max_array_index_length	= 256
                      hphp.cookie.max_array_index_length      = 256
                      hphp.request.max_array_index_length	= 768
                      
                      hphp.get.max_name_length		= 256
                      hphp.post.max_name_length		= 256
                      hphp.cookie.max_name_length		= 256
                      hphp.request.max_varname_length		= 256
                      
                      hphp.get.max_totalname_length		= 10000
                      hphp.post.max_totalname_length		= 10000
                      hphp.cookie.max_totalname_length	= 10000
                      hphp.request.max_totalname_length	= 30000
                      
                      hphp.get.max_value_length		= 512
                      hphp.post.max_value_length		= 500000
                      hphp.cookie.max_value_length		= 10000
                      hphp.request.max_value_length		= 510512
                      
                      hphp.get.max_vars			= 256
                      hphp.post.max_vars			= 1024
                      hphp.cookie.max_vars			= 256
                      hphp.request.max_vars			= 1536
                      http://www.teamxbox.com

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X