Announcement

Collapse
No announcement yet.

uploading attachment goes to blank

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • uploading attachment goes to blank

    i use file based attachment system

    my file is 6.8megs

    PHP Max Post Size8.00 MB
    PHP Maximum Upload Size7.00 MB
    when i try to upload the file
    it ends up with "the page cannot be displayed" error page

    whats going on.....is it because of time out??...

    smaller files would work

    what can i do...
    Last edited by superbunny; Mon 19th Dec '05, 8:47am.

  • #2
    it says file upload have NO problem
    when i tried the same file using the admincp diagnostics upload

    anyone have any ideas?

    Comment


    • #3
      more info...it seems to happen after 30secs of uploading
      that it goes to the error page

      i put in php_value max_execution_time 60
      in htaccess....but still goes to the error page after 30secs...

      any help appreciated

      Comment


      • #4
        This is almost certianly a timeout issue. Increase max_execution_time to 120 and try again.

        Also in addition to the vB settings, the allowed size of the attachments depends on the PHP and MySQL configuration. You may need to check and change the upload size for both PHP and for MySQL. Note, you'll need to have root access to the server to do this (or have your host do it.) Make these changes to php.ini:

        upload_max_filesize = xM

        ..and my.cnf (or my.ini for Windows systems)

        set-variable=max_allowed_packet=xM

        Change it to the size ('x') you want in Megabytes. Restart the webserver and MySQL after making these changes.

        Note: You may also need to increase the max_execution_time and max_input_time variables in php.ini.

        Also you might want to take a look at this for other settings that affect file uploads:

        http://www.vbulletin.com/forum/showp...0&postcount=12
        http://www.vbulletin.com/forum/showt...319#post748319
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          still the same....

          "mysql packet size" wouldn't matter since i am not using mysql for attachment correct?

          this is my current htaccess

          php_value post_max_size 12M
          php_value upload_max_filesize 10M
          php_value max_execution_time 2400
          php_value max_input_time 2400

          the only other thing i saw from those two posts is the

          LimitRequestBody....but i don't want to change this, since this will affect the whole server...plus I don't see the LimitRequestBody in php.conf or httpd.conf

          and my memory limit is twice the size of my upload file

          I spent hours on this already, but still not getting anywhere =(
          any other tips?
          Last edited by superbunny; Mon 19th Dec '05, 11:44am.

          Comment


          • #6
            Those are all the settings I know of that would affect this. Sorry.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              I to am unable to upload files larger then 10MB to my server. I have complete access to my php.ini files at the settings are:

              max_execution_time = 5000 ; Maximum execution time of each script, in seconds
              max_input_time = 5000 ; Maximum amount of time each script may spend parsing request data
              memory_limit = 55M ; Maximum amount of memory a script may consume (8MB)
              post_max_size = 80M

              You can view my servers php information here: http://www.scifi-meshes.com/phpinfo.php

              I have tried just about everything I can to figure out what's stopping the large uploads, but I am still at a loss. I have even checked my.cnf file (mysql) to ensure that's the not the issue and everything looks fine.

              Mayday! (I'm actually searching outside vb.com for answer now.. ::cry:

              Scifimeshes.com
              "Imagination is more important than knowledge" - Albert Einstein

              Comment


              • #8
                Solution Found:

                If you're having problems uploading large files but small files go through fine, here are some things to try:

                - In the HTML form, make sure you've set MAX_FILE_SIZE to an acceptable value.
                - In php.ini, be sure you've set the the upload_max_filesize and post_max_size to be large enough to handle your upload.
                - In your httpd.conf (if you're using apache), check that the LimitRequestBody directive isn't set too low (it's optional, so it may not be there at all).

                My server's httpd.conf file LimitRequestBody was set to 10MB (10000000) so I merely set to too 100000000 (100MB) and restarted apache (apachectl graceful) and it's working!

                Scifi-meshes.com
                "Imagination is more important than knowledge" - Albert Einstein

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X