Announcement

Collapse
No announcement yet.

Imagemagick not working, is installed.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Imagemagick not working, is installed.

    My host assures me that they have IM v6.X installed, and that the path is /usr/bin, however at the moment I'm stuck with GD. And don't want to be...

    Attached is a screenshot of the AdminCP for image settings.
    The error given is:

    ImageMagick Error
    sh: /usr/bin/identify: No such file or directory Upgrade ImageMagick to 6.0 or newer


    If useful:
    http://www.churchtech.co.nz/forums/i...hp?&do=phpinfo

    Any ideas?

    Thanks!
    Attached Files

  • #2
    You are seeing the direct output of the command:

    /usr/bin/identify

    No such file or directory

    identify
    is most likely not really there.

    Comment


    • #3
      Hmmm.

      In an effort to sort this out, here are the replies from my webhost.


      Hi Paul
      The version of ImageMagick we have installed isn't the very latest version (v6.21), so perhaps vBulletin needs a newer version to work properly? If you can find out any information regarding that, please let us know.
      Thanks
      I believe anything v6.x will be fine however?...
      I asked them to verify the binaries are there. They have confirmed this:


      Hi Paul
      The binaries are definitely in the /usr/bin directory, and appear to work fine.
      If you go to the following page, you should see the output of the 'identify' program.


      (Gives a weblink link which ends in "identify.php", which displays the following text: daz-aviator.jpg JPEG 640x480 DirectClass 26kb 0.020u 0:01)


      If you can find out anything from the vBulletin people, please let us know. I'll see what I can do about upgrading to the latest version as well.



      Sigh...


      Comment


      • #4
        Ask them to install the latest verison of GhostScript and then Install ImageMagick.

        Comment


        • #5
          Any version of 6 will work and 6.21 is fine. What is the content of the identify.php script?

          Zachary: Ghostscript will not fix this issue.

          Comment


          • #6
            All that displays on the web link given is
            daz-aviator.jpg JPEG 640x480 DirectClass 26kb 0.030u 0:01
            and when in IE I go view>source that's all that's there as well. Nothing more.

            Is this what you mean?
            Thanks for the assistance, it is appreciated!

            Comment


            • #7
              He means the php code, you'd need to view the actual file.

              Comment


              • #8
                Gotcha! Ill ask them for it and be back soon... Fingers crossed.

                Comment


                • #9
                  Ok you asked for it...

                  It would seem that this is it in entirety!

                  PHP Code:
                  <?php
                  passthru
                  ("/usr/bin/identify daz-aviator.jpg");
                  ?>

                  Comment


                  • #10
                    Open a support ticket with FTP information and a Admin login to your forums. Make a note to let support know to assign it to me.

                    Comment


                    • #11
                      Thanks! Done.

                      Comment


                      • #12
                        Gromits, did this get resolved for you?

                        If so, what was the problem?

                        Thanks.

                        Comment


                        • #13
                          Imagemagick wasn't installed on his server.

                          Comment


                          • #14
                            Hiya, thanks for the interest.

                            As Freddie points out, it was revealed that there was confusion as to which website I needed IM on. It turned out the server that I had my vB site on (I have more than one site) did indeed not have IM installed.

                            They installed it and ghostscript and all is well in the world again...

                            Comment

                            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                            Working...
                            X