Announcement

Collapse
No announcement yet.

Upgrade.php is a blank page

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Upgrade.php is a blank page

    Hey guys, I've been doing vBulletin installs and Upgrades since 2.3.0. I uploaded all the new files to my domain. and went to the install.php file. Afterwards I was directed to the upgrade.php file as I've always been to upgrade from 3.5.0 to 3.5.2. When I go to the page is just a white blank screen. Acually every upgrade_ file is all white blank pages.

    This is the screen I'm talking about:

    Step 2) Connect to the database

    Attempting to attach to database

    Connection succeeded! The database already exists.

    You have already installed vBulletin; do you wish to upgrade?

    Do you wish to empty your database for a new install?
    I've redownloaded the entire package and uploaded it all over again, overwriting my old files and it has the same affect. Anyone know what
    could be causing this? Thanks!

    Ken
    Ken Iovino
    Full Time PHP, Ruby and iOS Developer

  • #2
    The white pages are due to one of these causes:

    1. You did not upload the vB files correctly. Reupload the vB non-image files and make sure you upload these in ASCII format and that you overwrite the ones on the server. Make sure you upload the Admin CP files to the admincp directory specified in your config.php file.

    2. You have extra space or lines in your config.php file. Make sure there is no whitespace or extra lines in config.php either before the <?php or after the ?>.

    3. Your PHP has magic_quotes_sybase turned on. You have to run this off. On *nix systems you can do this by creating an .htaccess file with this content and placing it in your main forum directory:

    php_flag magic_quotes_sybase 0
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Thanks Steve, it was because magic_quotes_sybase was turned on and making the .htaccess file worked perfectly. Thank you again
      Ken Iovino
      Full Time PHP, Ruby and iOS Developer

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X