Announcement

Collapse
No announcement yet.

Cannot upload plugins, avatars, pictures, or smilies

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot upload plugins, avatars, pictures, or smilies

    Hi, for some reason i cannot upload anything at all. However, some files do upload for the avatar while others don't. I am getting the error when i try to upload avatars via admin panel:

    There was an error encountered with your upload:
    • Imageinfo Failed:
    And when i try to upload in my usercontrol panel i get the same message or upload file failed.

    What is the problem? As far as chmod 0777 goes, I have no idea if i can do that since i am hosted by godaddy. If anyone has changed that, please let me know how. All help is appreciated!

    If you would like to look at it first hand, my forum is at http://www.advertisespace.com/forums/

  • #2
    GoDaddy has lots of problems as a host. Run the Upload Diagnostics and report back the results:

    Admin CP -> Import & Maintenance -> Diagnostics -> Upload

    Also, in the Admin CP, open the Server Settings and Optimization Options section and turn on the Public phpinfo() Display Enabled setting. This may help us troubleshoot this problem.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Diagnostics run and i get this:

      The test was indeterminate. There were problems reading the uploaded file, but none of PHP's settings were identified as causing a problem. At this point, you should attempt to attach a file to a post. If that fails, contact your host as no one will know their own server setup better than them.

      I have set the Php Info display setting to yes. Please let me know what i should do.

      Comment


      • #4
        Your forums are producing a 'Page Not Found' error so I can't check this out:

        http://www.advertisespace.com/forums/
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Sorry I just switched the folder name:

          http://www.advertisespace.com/forum/

          I can upload pictures as avatars, but they are much bigger than 19.5kb, which is very strange. It automatically resizes them, but if i try to upload something smaller, it doesnt work.

          Comment


          • #6
            Two issues:

            1. You have safe mode enabled on this server. You need to enable safe mode in the Admin CP and set the Safe Mode Temp Directory to a directory that has been chmod'd to 777. Use the full path to that directory on the server.

            2. This is a Windows server and it requires that an upload_tmp_dir directory be set in php.ini. Right now this setting is blank. Your host will need to create a world-readable and writable directory on this server, then edit php.ini to set the upload_tmp_dir setting to this directory.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Ok i change it to safe mode and now how do i get godaddy to write that upload_tmp_dir file? Will they do this or can i do this?


              Can these temp files be located on another websites directory or does it have to the same?

              Comment


              • #8
                In my experience GoDaddy will not make the necessary change for you, which is why I warned about them. You might want to ask them to switch you to a Linux server.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Ok they are in the process of switching it to a Linux server, will i have these problems upon completion or should all run well?

                  Comment


                  • #10
                    That depends on the server configuration.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Changed to Linux, problem solved. Thanks Steve.

                      Comment


                      • #12
                        Glad to hear it. For some reason the GoDaddy Windows servers have lots of problems.
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X