Announcement

Collapse
No announcement yet.

Search type - how to change it manually?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Search type - how to change it manually?

    Hi folks,
    because we have 1.8 million posts, the control panel search type change timed out.
    I have manually run the two SQL statements ok (or rather my host did with ssh), but the control panel setting still reports that we're using the old vBulletin search. How do I change this? Does it matter?
    Stuart Wright, founder AVForums.com. [strike]13[/strike] 15 million posts and counting.
    vBulletin user from 2001. We stopped upgrading vB at 3.8.2 and sadly we're going no further.

  • #2
    Which version of MySQL are you running? Did you check the database to make sure those queries completed?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      I'm curious about this too ... especially since we have over 5.2 million posts, I know the control panel option will probably die a horrible death.
      Kevlar
      Bimmerforums - The Ultimate BMW Forum

      Comment


      • #4
        MySQL 4.1.15-Max and the queries didn't complete so we did it manually as per the instructions on the page.
        I wasn't surprised that it timed out. The database repair function always times out on the post table.
        I had to get my host to run the SQL statements directly using telepathy.
        Last edited by Spinball; Tue 13th Dec '05, 11:44am.
        Stuart Wright, founder AVForums.com. [strike]13[/strike] 15 million posts and counting.
        vBulletin user from 2001. We stopped upgrading vB at 3.8.2 and sadly we're going no further.

        Comment


        • #5
          Yes, how do we manually change the Search Type flag? Not how do we run the Alter queries, but change the Search Type to Fulltext without going through VB control panel?

          Thanks!
          Ryan DeLuca
          Bodybuilding.com

          Comment


          • #6
            I think I found it. Change the value to 1 where the varname = fulltextsearch in the setting table. (After manually running the Alter queries to add fulltext to the tables.)

            Anyplace else that needs to be changed?

            Ryan

            Comment


            • #7
              That's all, just make sure to edit any option and save it to get your change activated.

              Comment


              • #8
                Hmm... I manually changed this setting to value = 1 and it didn't seem to work. I then changed it to -1 and it worked, but that doesn't seem right. What am I missing?

                Edit any options? Not sure what you mean.

                Ryan

                Comment


                • #9
                  Oh, do you mean edit any option so VB will reload the setting table? It seems to be working now. I changed it back to value=1.

                  Ryan

                  Comment


                  • #10
                    Yes, the settings table is only one place that vairble is refrenced.

                    You need to rebuild its cache.

                    Comment


                    • #11
                      Hm, could you explain this for dumb ones like me?
                      Is it like this: UPDATE `setting` SET `value` = '1' WHERE `varname` = 'fulltextsearch' LIMIT 1 ;
                      Last edited by Grendel; Wed 14th Dec '05, 2:30am.

                      Comment


                      • #12
                        No help?
                        I really would like to use the mysql-search but vBulletin won't let me...

                        Comment


                        • #13
                          If you've manually executed the queries to add the fulltext indexes, edit includes/config.php to include this line:

                          $config['Misc']['debug'] = true;

                          Then go into vBulletin->Options and you will see a new section called 'Version Info and Other Untouchables'. Change the 'Fulltext Search' setting to Yes. Now edit includes/config.php again and remove $config['Misc']['debug'] = true;

                          Comment


                          • #14
                            Great! Thank you very much.

                            Comment

                            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                            Working...
                            X