going from 3.0.8

Collapse
X
 
  • Time
  • Show
Clear All
new posts
  • scoles15
    New Member
    • Aug 2005
    • 12
    • 3.5.x

    going from 3.0.8

    I am using 3.0.8. It has hacks, modes, templates changes, vbadavanced stuff etc. From reading the various posts, this is my understanding of what will happen if I perform an upgrade. All customizations will be lost including templates and phrases. So one way or another, I am going to have re-apply almost everything custom. right now, I estimate that may take me up to 5 days to do and thus up to 5 days that my site will be down. Which is not a good thing from my customer base's point of view.

    So, I was wondering if the following would work.

    Clean install of 3.5.1 or whatever version is latest.
    Make all my changes, addons, etc.
    Then imppex my old installation to the new.
    First will it work? And second will everything else come over, forums, threads, posts, calandar, users, usersgroups, titles, ranks, etc.

    Thanks for any help, advice, etc. anyone can provide
    Steve Coles
    www.ncwoodworker.net
  • Dan
    Senior Member
    • Dec 2002
    • 698

    #2
    Yep that should work perfectly fine, I spent a good 2 weeks working on a perfect install and pulled all users and posts via impex.

    Comment

    • feldon23
      Senior Member
      • Nov 2001
      • 11291
      • 3.7.x

      #3
      Originally posted by scoles15
      I am using 3.0.8. It has hacks, modes, templates changes, vbadavanced stuff etc. From reading the various posts, this is my understanding of what will happen if I perform an upgrade. All customizations will be lost including templates and phrases.
      This is inaccurate. Your templates and phrases will be maintained. In fact that will be 'frozen' at 3.0.x levels which is almost worse than what you describe. Functionality added in 3.5 will likely NOT appear on your 3.5 forum because of outdated templates and may even prevent users from being able to post (the posting system was wisely rewritten from the ground up -- you'll end up with new PHP and Javascript and old templates battling each other).

      Originally posted by scoles15
      I was wondering if the following would work.

      Clean install of 3.5.1 or whatever version is latest.
      Make all my changes, addons, etc.
      Then imppex my old installation to the new.
      First will it work? And second will everything else come over, forums, threads, posts, calandar, users, usersgroups, titles, ranks, etc.

      Thanks for any help, advice, etc. anyone can provide
      That's exactly what I would do. Realize that most 'hacks' have been rewritten for the new Plugins system in vBulletin 3.5. It is possible to extend vB in many ways without editing PHP files and in some cases without editing templates just by uploading XML files which contain snippets of PHP code, custom templates, etc.

      So that there are no surprises, check over on vBulletin and make sure that there are 3.5 versions of each of your hacks. 3.0.x hacks do not work on 3.5 because many of the variable names changed.

      Comment

      • scoles15
        New Member
        • Aug 2005
        • 12
        • 3.5.x

        #4
        Thank you very much for help. Now all I have to do it find out if I can the same thing vbadvanced gallery and vbadvanced links and a couple of others where there is data in the DB already
        Steve Coles
        www.ncwoodworker.net

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        😀
        😂
        🥰
        😘
        🤢
        😎
        😞
        😡
        👍
        👎