Announcement

Collapse
No announcement yet.

Search Engine Not Functioning Properly

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Search Engine Not Functioning Properly

    I have no problems or "errors" when I use the search engine, but when I search for "key words" it finds nothing....not even when I kNOW for a fact that there should be threads that pop up in the search. If I search for a username, then it works. What could be causing this?

  • #2
    The forum in question is:

    www.bpgforums.com

    Comment


    • #3
      Using the built in search or fulltext? If built in, did you try rebuilding your search indexes?

      What word are you searching for?
      vBulletin v3.8.0's Implementation of Google Adsense Should Be Avoided At All Costs - Do Your Own Adsense Implementation

      Comment


      • #4
        every word I can think of..

        "Buick" would be the first and most common word to find.

        How do I find out if I am using fulltext or built in?

        Comment


        • #5
          It appears you are using vBulletin's built-in search and the searchindex is empty. You need to rebuild the search index under Maintenance -> Update Counters -> Rebuild Search Index or switch to MySQL's Fulltext search under vBulletin Options -> Search Type.
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud demonstration site.
          vBulletin 5 API - Full / Mobile
          Vote for your favorite feature requests and the bugs you want to see fixed.

          Comment


          • #6
            Does it take some time to actually take effect? I rebuilt the search index and I'm still coming up with nothing.

            Comment


            • #7
              It should be in affect as soon as the search index is rebuilt. Did you check each of the forums to make sure that 'Index New Posts in Search Engine ' is set to 'Yes'?
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                Steve,

                I don't have much time this morning, but I checked one of the forums, and it is set to NO. I wonder why they're all set to no? Is that a default thing that sets itself when you upgrade?

                Comment


                • #9
                  No, they do not reset during an upgrade. I'm not sure why this happened.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    Thanks for your help, Steve. It works great now!

                    Comment


                    • #11
                      Hey there ..

                      yesterday we switched towards vbb 3.5.1 only to find out that we have the exact same problem.

                      "Index New Posts in Search Engine" is set to no in all our 25 forums sections.

                      Comment


                      • #12
                        I found the query to turn on indexing for all forums at once. This assumes no table prefix of course:

                        UPDATE forum SET options = options+16384 WHERE NOT (options & 16384);
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X