Announcement

Collapse
No announcement yet.

Database error in vBulletin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Database error in vBulletin

    Hi,
    my host recieved today more than 17000 (as they mentioned to me) messages in email queue from vBulletin about DB error like the following:

    Code:
    Database error in vBulletin :
    mysql_connect(): Too many connections
    /usr/www/***/***.com/www/forums/includes/class_core.php on line
    273
    MySQL Error  : 
    Error Number : 
    Date         : Tuesday, November 15th 2005 @ 08:35:04 PM
    Script       : http://***.com/forums/login.php
    Referrer     : http://***.com:80
    IP Address   : 209.158.71.*
    Username     : 
    Classname    : vb_database
     
    --------
     
    Database error in vBulletin :
    mysql_connect(): Too many connections
    /usr/www/***/***.com/www/forums/includes/class_core.php on line
    273
    MySQL Error  : 
    Error Number : 
    Date         : Tuesday, November 15th 2005 @ 08:34:34 PM
    Script       : http://www.***.com/forums/
    Referrer     : http://www.***.com/
    IP Address   : 69.70.32.*
    Username     : 
    Classname    : vb_database
    I'm using vBulletin 3.5.1

    Server info...
    -
    FreeBSD (4.11)
    -
    PHP (4.4.1)
    -
    MySQL (4.1.10a):
    mysql.allow_persistent On
    mysql.connect_timeout 60
    -
    Apache (1.3.33):
    Max Requests: Per Child: 16 - Keep Alive: off - Max Per Connection: 32
    Timeouts: Connection: 10 - Keep-Alive: 10
    -

  • #2
    The server has maxed out the number of MySQL connections it allows. You can try turning persistent connections off in your config.php:

    $config['MasterServer']['usepconnect'] = 0;

    But if you still have problems after that, all you can do is ask your host to raise the maximum number of connections they allow.

    Here is more info on that error:

    http://www.mysql.com/doc/T/o/Too_many_connections.html
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment

    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
    Working...
    X