Announcement

Collapse
No announcement yet.

Large Attachment Problem.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Large Attachment Problem.

    I'm trying to upload a 10MB file and i receive this error:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 11254047 bytes) in /*******/includes/class_core.php3 on line 1696

    I've tried freddies suggestion of adding this line to config.php for which he said in another post but this doesn't make any difference.

    ini_set('memory_limit', '16M');

    File uploads work up to about 8MB anything over doesn't

    Any Suggestions?

  • #2
    In addition to the vB settings, the allowed size of the attachments depends on the PHP and MySQL configuration. You may need to check and change the upload size for both PHP and for MySQL. Note, you'll need to have root access to the server to do this (or have your host do it.) Make these changes to php.ini:

    upload_max_filesize = xM

    ..and my.cnf (or my.ini for Windows systems)

    set-variable=max_allowed_packet=xM

    Change it to the size ('x') you want in Megabytes. Restart the webserver and MySQL after making these changes.

    Note: You may also need to increase the max_execution_time and max_input_time variables in php.ini.

    Also you might want to take a look at this for other settings that affect file uploads:

    http://www.vbulletin.com/forum/showp...0&postcount=12
    http://www.vbulletin.com/forum/showt...319#post748319
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      What should the max execution time and input time be for a 10MB file?

      It's currently at:

      max_execution_time 30
      max_input_time 60

      Comment


      • #4
        What should the max execution time and input time be for a 10MB file?

        It's currently at:

        max_execution_time 30
        max_input_time 60

        P.S it use to work on version 3.0.1

        Comment


        • #5
          It really depends on the server and the connection but I would try setting max_execution_time to 120.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            It's working now, thanks. It was timing out, so i adusted the times.

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X