Announcement

Collapse
No announcement yet.

ImageMagick image in admin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ImageMagick image in admin

    I am missing the ImageMagick example image in the admin panel, it's a red x next to GD. Where is this image located? Thanks

  • #2
    It will be a red X if you haven't entered the path to ImageMagick in the proper place below. You may not have access to ImageMagick, which means that the image will never appear for you.

    Comment


    • #3
      Great, thanks.

      Comment


      • #4
        I have the latest and greatest IM installed (says my host) and I cant figure out the path.. Any help?
        Home of the free, Because of the brave.

        Comment


        • #5
          Did the host not give you the path? If you have it, what is it and what did you enter in the path input?

          Comment


          • #6
            It will usually be one of the two locations below for your path (if it is installed):

            /usr/bin
            /usr/local/bin

            Comment


            • #7
              I'm also getting the red 'x' in admincp - i have my path set to /usr/bin/ (also tried /usr/bin). It detects the fonts ok.

              I verified the path via SSH and as has been mentioned earlier, I too have other apps (Photopost etc) that find and use Imagemagick 6.2.0 without an issue.

              Any ideas, thanks.

              Comment


              • #8
                What is the url to your forum?

                Comment


                • #9
                  I couldn't get IM to work either, the fonts never displayed, and the path was correct, so I'm going with GD.

                  Comment


                  • #10
                    If you can't get IM to work, you should submit a support ticket and I can tell you what the problem is.

                    Comment


                    • #11
                      I contacted my server today and told them that the latest version of vBulletin 3.5 now used ImageMagick as well as GD and would not work on there servers because they had "Imagemagick 5", and it reqired version 6 or higher to be installed. I said it would be in there best interest to update there server version to ImageMagick 6 or higher for vB users.

                      They sent me an email back saying this:

                      Hello,

                      Imagemagick is now upgraded to version : ImageMagick 6.2.3. on our servers. Hope this may solve your problem for vB 3.5.

                      Please revert back to us in case of any queries, we will be glad to assist you.
                      But I still have a problem that I wanted to ask here before contacting my server again. I used this path "/usr/local/bin" and it shows me a white box without a font used or any text in the box. So it seems the path is correct.

                      But in the setting below it that says: ImageMagick Font
                      Its shows no fonts to choose from and just says "ImageMagick Error"

                      Any advice on this?
                      Last edited by MRGTB; Sat 19th Nov '05, 4:15pm.

                      Comment


                      • #12
                        im also getting a similar problem but i font shows and the picture doesnt?

                        Comment


                        • #13
                          ImageMagick must be compiled with freetype2 support and to use fonts you need to install GhostScript before ImageMagick.

                          vB 3.6 won't require ghostscript, but 3.5.1 does. If you submit a support ticket directed to me, I can determine what your exact problems are and how to alleviate them.

                          You can go directly to image.php on your server and it may give you an indication of what the issue is.

                          http://www.vbulletin.com/forum/image.php?type=im

                          Replace vbulletin.com with the url to your forum.

                          Comment


                          • #14
                            Ask you server what version of ImageMagick there are running, if they are running version 5 they need to update to version 6 for it to work with vBulletin 3.5. I was getting a blank box also with an X until they updated today, but now it looks like my server has not installed the FONTS needed for it to work. I just sent them an email telling them this might be the problem. No fonts for it.

                            Were as yours looks like your version is the wrong version, try using:

                            /usr/local/bin

                            -----------------------

                            But I need some advice as to if an expert here thinks thats the problem with mine, ImageMagick FONTS not installed?

                            Comment


                            • #15
                              Originally posted by Freddie Bingham
                              ImageMagick must be compiled with freetype2 support and to use fonts you need to install GhostScript before ImageMagick.

                              vB 3.6 won't require ghostscript, but 3.5.1 does. If you submit a support ticket directed to me, I can determine what your exact problems are and how to alleviate them.

                              You can go directly to image.php on your server and it may give you an indication of what the issue is.

                              http://www.vbulletin.com/forum/image.php?type=im

                              Replace vbulletin.com with the url to your forum.
                              I have the site password protected right now, as I already have a live site online using 3.0.9 and only own one licence. But I just entered this:
                              http://www.garybolton.co.uk/forum/image.php

                              and it showed me a box image with text saying vbulletin. I can PM you the details to see the image if you want

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X