Announcement

Collapse
No announcement yet.

Attachments are corrupt in 3.5

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Attachments are corrupt in 3.5

    ...and none of them are showing up. I get the "The image you are trying to view has errors." message.

    I've already tried re-uploading the vB files in ASCII and changed the Attachment Storage Type to no avail....

    Any suggestions?
    [email protected]
    BondMovies.com - "Nobody Does It Better."

  • #2
    First we need to know what you changed just prior to the attachments becoming corrupted.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      My users noticed attachments were not working (were corrupted) after my upgrade from vB 3.0.8 to 3.5.0...
      [email protected]
      BondMovies.com - "Nobody Does It Better."

      Comment


      • #4
        Define "were not working" specificly. Can't download? Can't Open? If can't open which ones? is it just zip files?

        Comment


        • #5
          There is nothing in the upgrade process that would cause this. Did you backup and restore the database by any chance?
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Originally posted by Steve Machol
            There is nothing in the upgrade process that would cause this. Did you backup and restore the database by any chance?
            Yes. But now I can't even upload a new attachment to a post...


            As for Zachery's Q, whenever I try to view any attachment I get the "image is broken/corrupt" error message.
            [email protected]
            BondMovies.com - "Nobody Does It Better."

            Comment


            • #7
              Why did you backup and restore the db? This is the most likely cause of this problem.

              There is a corruption problem with shell backups for vB 3.0.x made with the mysqldump from MySQL 4.1.x. To fix this problem, run these queries on the db prior to making the backup:

              ALTER TABLE attachment CHANGE filedata filedata MEDIUMBLOB NOT NULL, CHANGE thumbnail thumbnail MEDIUMBLOB NOT NULL;

              ALTER TABLE customavatar CHANGE avatardata avatardata MEDIUMBLOB NOT NULL;

              ALTER TABLE customprofilepic CHANGE profilepicdata profilepicdata MEDIUMBLOB NOT NULL;

              We found that a character set issue in MySQL 4.1.x is at fault. Converting these fields to mediumblob fixes the problem.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                Upgrading to 3.0.8 or directly to 3.5.0 from the working backup will avoid the problem.

                Comment


                • #9
                  Alright well...In my situation...Where my 3.5 board is up and running and attachments aren't working, what should I do?

                  Back-up and restore?
                  [email protected]
                  BondMovies.com - "Nobody Does It Better."

                  Comment


                  • #10
                    Restore the pre-upgrade database, upgrade to 3.0.9, then upgrade to 3.5.0.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Seeing as how my last backup of my 3.0.8 database is from over two weeks ago, there is no way I am willing to go with that option.

                      Is it looking like I should just disable attachments in my forums? Am I really out of options here?
                      [email protected]
                      BondMovies.com - "Nobody Does It Better."

                      Comment


                      • #12
                        There is no way to fix attachments that are already corrupted.
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment


                        • #13
                          I understand that. Is there some way to allow for new attachments to be posted, uncorrupted?

                          That is, without back-up, restore, etc...?

                          What a bummer this is...

                          EDIT: By the way:

                          Originally posted by Freddie Bingham
                          Upgrading to 3.0.8 or directly to 3.5.0 from the working backup will avoid the problem.
                          I upgraded from 3.0.8 directly to 3.5.0
                          [email protected]
                          BondMovies.com - "Nobody Does It Better."

                          Comment


                          • #14
                            If you have installed any Plugins, first disable these to see if you still have this problem.

                            If you have not installed any plugins or hacks (which includes portals), fill out a support ticket at:

                            http://members.vbulletin.com/members...ontactform.php

                            Be sure to include the login info to your Admin CP, phpMyAdmin and FTP.
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment

                            Loading...
                            Working...
                            X