Announcement

Collapse
No announcement yet.

Load balanced forum issue - 2 servers 1 SQL server

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Load balanced forum issue - 2 servers 1 SQL server

    We run a load balancer with 2 front end boxes and a dbase server.

    Every hour I get an email from VB - with this:

    Database error in vBulletin :

    mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Can't connect to MySQL server on '******' (4) /usr/home/customers/*******/forums*******.net/www/includes/class_core.php on line 273

    MySQL Error :
    Error Number :
    Date : Monday, October 17th 2005 @ 02:51:11 PM
    Script : http://forums.*******.net/showthread.php?t=57385&page=2
    Referrer : http://forums.*******.net/forumdisplay.php?f=49
    IP Address : **************
    Username :
    Classname : vB_Database

    We own all the kit so configs can be changed.

    Server 1 mirrors to server 2 every hour. But at differnet times, some at 10 past, some at 10 to - etc.

    The mirroring runs at 0,15,30 * * * * root sh /home/rsync.sh

    So its nothing to do with that. The sync takes around 10 seconds tops.

    There is nothing else running on the hourly thing?

    Any help would rock

  • #2
    I am not sure why it can not connect, it sounds like the server is locked for syncing or perhaps restarting.

    Comment


    • #3
      The trouble is we don't get *that* many emails, 10 an hour tops - and sometimes none.

      Its a pain in the butt we can't see any pattern

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X