Announcement

Collapse
No announcement yet.

Cannot login without remember me checked

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot login without remember me checked

    When I go to my board at www.sandrabullockcentral.com I am only logged in when I click remember me. When I don't click it it says logged in succesfully and it redirects me to the start page without being logged in. I am shown in who is online though. Quite everyone on my board seems to have this problem. Reverting the navbar template didn't help.

    I am using IIS 6, PHP 4.4.0 ISAPI with MySQL 4.0.24 and on my test server same PHP but MySQL 4.1.13. Both servers have the same issue.

    I don't have the problem on vbulletin.com so it's no general bug in vB. I tried to add standard http headers since the vB options say might be needed on some IIS setups. That doesn't solve the problem or change anything though.

    Thanks for any advice in advance!
    Last edited by Chrissicom; Fri 16 Sep '05, 1:00am.
    "I have emotional vices and they can be far more paralyzing than drugs or alcohol."
    -Sandra Bullock


    Sandra Bullock Central Message Board / Chris' Famous Sandra Bullock Page / Sandra Bullock News (Deutsch)

  • #2
    Sounds a lot like this problem in the Bug Tracker: http://www.vbulletin.com/forum/bugs3...iew&bugid=1258

    There's a fix posted there by Scott MacVicar toward the end of that thread. Try it and see if it helps.
    ~ Life isn't always fair, but you can be. ~

    Comment


    • #3
      Ok this is a fix for the first login bug, not sure if its related or not so listen up.

      Open class_core.php

      look for

      Code:
      vbsetcookie('sessionhash', $sessionhash, 0);
      replace with


      Code:
      if (!defined('SKIP_SESSIONCREATE'))
      {
      vbsetcookie('sessionhash', $sessionhash, 0);
      }
      There may be more bugs so feedback is appreciated AFTER you've applied this patch.
      I applied this patch but it didn't solve my problem, actually nothing changed. I didn't experience any random logouts and there were also none reported in my own bugs forum.
      I still have the same issue in short words:
      - I log in anywhere where I am asked to without remember me checked
      - it says thank you for logging in and I am redirected
      - I am shown in who is online on forumhome but besides that I am not logged in, still see the enter username and password field
      "I have emotional vices and they can be far more paralyzing than drugs or alcohol."
      -Sandra Bullock


      Sandra Bullock Central Message Board / Chris' Famous Sandra Bullock Page / Sandra Bullock News (Deutsch)

      Comment


      • #4
        What is your cookie prefix listed in config.php? Try changing it?

        Make sure not to play with the cookie settings in the Admin CP as they are quite useless and if you screw up, you cant get back in

        Comment


        • #5
          cookie prefix is standard = "bb". The CP settings are fine as well path is / and domain is .sandrabullockcentral.com
          "I have emotional vices and they can be far more paralyzing than drugs or alcohol."
          -Sandra Bullock


          Sandra Bullock Central Message Board / Chris' Famous Sandra Bullock Page / Sandra Bullock News (Deutsch)

          Comment


          • #6
            Try changing the cookie prefix. And then clear all of your cookies. (Yes, all of them)

            Comment


            • #7
              doesn't help sorry, I tried cleaning cookies before as well... standard procedure
              "I have emotional vices and they can be far more paralyzing than drugs or alcohol."
              -Sandra Bullock


              Sandra Bullock Central Message Board / Chris' Famous Sandra Bullock Page / Sandra Bullock News (Deutsch)

              Comment


              • #8
                O.K one last thing, after this I think I'm all out of ideas.

                Upload tools.php from the do_not_upload folder and reset the cookie settings. See what happens.

                Sorry if that doesn't help.

                Comment


                • #9
                  Well I tried it but as I expected it didn't help, except for the domain I have never changed any cookie settings and I would have been surprised if setting the domain to .sandrabullockcentral.com caused this problem. Thanks for your help anyway.
                  Well I am really out of ideas now. I reverted the templates all to standard on my test server and it shows the same issue as my production server. But it can't be a general vB bug since I can login here without remember me checked. Any other ideas?
                  "I have emotional vices and they can be far more paralyzing than drugs or alcohol."
                  -Sandra Bullock


                  Sandra Bullock Central Message Board / Chris' Famous Sandra Bullock Page / Sandra Bullock News (Deutsch)

                  Comment


                  • #10
                    wait if you have two installations, they cant both have the same cookie prefix...make sure they both have unique ones. Then clear your cookies...

                    Comment


                    • #11
                      errrm.... I have a test computer that is not connected to the internet runnig the same licence as my production server. I don't think these two installations interfer in any way. I just try out stuff on the test server before I put it on the production server.

                      Anyway the login problem is still not solved and my users get quite annoyed by it. Anyone else with an idea?
                      "I have emotional vices and they can be far more paralyzing than drugs or alcohol."
                      -Sandra Bullock


                      Sandra Bullock Central Message Board / Chris' Famous Sandra Bullock Page / Sandra Bullock News (Deutsch)

                      Comment


                      • #12
                        chrissicom--

                        did you ever figure this out. this just started happening to me, and i can't figure it out either.

                        -d

                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X