Announcement

Collapse
No announcement yet.

Session table fills up.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Session table fills up.

    For some reason it seems like rows in the session table are no being deleted. I hit 32K and change on Sunday and again today. I had to empty the session table so it can start doing it's job again.
    Last edited by Abe1; Fri 16 Sep '05, 1:46pm.

  • #2
    Did you edit your footer template? Often changes to this template can break the scheduled tasks function that empties this table on a regular basis.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Nope. No changes to it.

      Comment


      • #4
        Changes to any templates? The only other cause of this is that either you have removed one or more of the scheduled tasks, or you have added some code that is interfering with this function.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          How should sessions normal work? one per userid?

          Comment


          • #6
            Originally posted by Abe1
            How should sessions normal work? one per userid?
            Basicly yes, but AOL users are known to inflate that number a bit because their ip changes nearly every page load.

            Make sure the files /includes/cron/cleanup.php and /includes/cron/cleanup2.php are uploaded to the server and correct. If they are make sure they are in the scheduled task manager.

            Comment


            • #7
              I figured out the problem. MY CRON JOBS STOPED RUNNING AFTER I UPGRADED TO vB3.5RC3!

              Any help?

              Comment


              • #8
                The first thing I recommend is that you reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server.

                Next, create a new style and choose no parent style. This will force it to use the default templates. Then change to this style and view your forums with it. Do you have the same problem?
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  No clue why the style would change anything but I did both. CRON jobs still dont run.

                  Comment


                  • #10
                    Originally posted by Abe1
                    No clue why the style would change anything but I did both. CRON jobs still dont run.
                    Are your pm popups working?

                    Comment


                    • #11
                      Originally posted by Freddie Bingham
                      Are your pm popups working?
                      Yes. I just tested. With and without plugins enabled. Both times I got a pop-up.

                      Comment


                      • #12
                        BTW, I just checked a test forum that I have on my home server, also no cron jobs since the update.

                        Comment


                        • #13
                          Scheduled Tasks work fine on an unmodified forum. Note that you have to have some forum activity to trigger these tasks.
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #14
                            Originally posted by Steve Machol
                            Scheduled Tasks work fine on an unmodified forum. Note that you have to have some forum activity to trigger these tasks.
                            What should I do now?

                            Comment


                            • #15
                              Honestly there is no reason for this not to work if you have done what I suggested in post #8 and your forums have regular traffic. My suspicion is that there is still a change you made that is keeping scheduled tasks from running.
                              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                              Change CKEditor Colors to Match Style (for 4.1.4 and above)

                              Steve Machol Photography


                              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X