Announcement

Collapse
No announcement yet.

Upgrade failure: 3.0.7 -> RC3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Upgrade failure: 3.0.7 -> RC3

    Tried upgrading my boards but i get this error :

    Step 1) Create New vBulletin 3 Tables

    We have detected that you have already tried to run the upgrade script. You will not be able to proceed unless you revert to a vB 2.2.x/2.3.x database.
    This happens after it updates my 3.0.7 to 3.0.8 and is now at the vBulletin v3.0.0 Beta 3 stage of upgrading ( at least thats what in the footer and the URL is install/upgrade_300b3.php?step=1 )

    Any advise ?
    Seems the upgrade this time is a messy issue.
    vbArticles.com, now open!
    Content Management for vBulletin, made easy

  • #2
    Did you install any hacks? This is either due to already running this upgrade once before, or a hack has added something to the database that conflicts with RC3.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Have only one hack installed which adds 2 new tables but doesnt alter structure of default vb tables.
      Also the upgrade hasnt been run before.
      Any other ideas ?
      vbArticles.com, now open!
      Content Management for vBulletin, made easy

      Comment


      • #4
        Originally posted by Steve Machol
        Did you install any hacks? This is either due to already running this upgrade once before, or a hack has added something to the database that conflicts with RC3.
        Does that mean that the database has to be 100% 3.07. Can't there be any extra tables/fields?

        Comment


        • #5
          Tried to update tables manually to forward to certain steps. Ran from 3.0.7 to RC3 updates ( even though there is a msg saying this script may not be for this version something along those lines ).

          However upon going to my boards again, this is the error i am getting:
          vBulletin datastore error caused by one or more of the following:

          1. You may have uploaded vBulletin 3.5 files without also running the vBulletin 3.5 upgrade script. If you have not run the upgrade script, do so now.
          2. The datastore cache may have been corrupted. Run Rebuild Bitfields from tools.php, which you can upload from the do_not_upload folder of the vBulletin package.


          Fatal error: vBulletin datastore cache incomplete or corrupt in /includes/init.php on line 171
          Tried to run that tools.php file but still the same.
          vbArticles.com, now open!
          Content Management for vBulletin, made easy

          Comment


          • #6
            Tried to:
            1- upgrade from 3.0.7 to 3.0.8.
            2- Then, upgrade from 3.0.8 to 3.5.0 RC3

            If the problem still,
            1- upgrade to 3.0.9.
            2- Then, to 3.5.0 RC3.

            Comment


            • #7
              Any help on the post i made above ?
              vbArticles.com, now open!
              Content Management for vBulletin, made easy

              Comment


              • #8
                It sounds like you skipped one or more steps in the upgrade. I suggest restoring a backup of your 3.0.7 database and trying again.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X