Announcement

Collapse
No announcement yet.

Question About Cookies...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Question About Cookies...

    Is it true that they will take longer to cook at lower elevations?
    Sorry, actually my question is that I have multiple domains that point to my site...for example:

    http://www.weapondepot.com is the main and http://www.reelandtrigger.com is parked.

    If I visit weapondepot while logged it all is fine, however, if I access the site via reelandtrigger, I am not logged in. I understand that is right, however, how do I change it so that no matter what domain they come in on, the cookies still show them logged on?

    It appears that I should change the cookie domain to .weapondepot.com, however, that did not work??

    Thanks for the help!!
    CommanderTalk.com --> www.commandertalk.com

  • #2
    Alright hmmm I thought I had figured it out, it appears as though left blank will allow all parked domains the ability to use the cookie.

    For example, leaving this setting blank will allow your forum cookies to operate on any domain on your site. If you have multiple domains parked on your site, then a forum cookie can be recorded for any of those domains depending on which domain is used to login to your forum.
    So I attempted to go into http://www.reelandtrigger.com to see if it would keep me logged into that domain, however, I get this error:

    "POST requests from foreign hosts are not allowed."

    Hmmm
    CommanderTalk.com --> www.commandertalk.com

    Comment


    • #3
      New setting in 3.5, browse to: AdminCP -> vBulletin Options -> General Settings

      And change this option:

      Post Referrer Whitelist
      For security purposes, vBulletin only allows data to be submitted via post from within the domain the board is installed on. If you are submitting post requests from a different domain or subdomain, you must add them here.

      Enter domains in the form of .domain.com (including the leading dot). Seperate multiple domains by line breaks.

      Comment


      • #4
        LOL sorry about that...I did not quite make it back quick enough to let everyone know I figured this out.

        Thanks for the reply...There is another problem though

        The problem is I have several domains parked and pointed to one main domain. If you access the site using one of the parked domains, and attempt to login, it tell you that login is successful, however, you still appear not to be logged in?

        Does this have something to do with the url still being listed in the address line?

        Here is an example:

        username: test
        password: test

        Go to http://www.atvpros.net and login (this is the main domain and lets you login without any issues)

        Now go ahead and logout and then revisit the site using http://www.trx450r.net (this is a parked domain, notice the address line, the url is still www.trx450r.net. Attempt to login, it will act as though you are logging on ok, but then takes you back to the index and appears to not be logged in. Just for fun, go ahead and click on Members List now...now it shows you as logged in.)

        Any thoughts??
        CommanderTalk.com --> www.commandertalk.com

        Comment


        • #5
          Originally posted by Brad.loo
          New setting in 3.5, browse to: AdminCP -> vBulletin Options -> General Settings

          And change this option:

          Post Referrer Whitelist
          For security purposes, vBulletin only allows data to be submitted via post from within the domain the board is installed on. If you are submitting post requests from a different domain or subdomain, you must add them here.

          Enter domains in the form of .domain.com (including the leading dot). Seperate multiple domains by line breaks.
          Question... so if we're not using 3.5 and we're using 3.0.7 - how can we work around this?

          I do like how it's included in 3.5 though - I've seen a lot of boards having this issue. What is the ETA on 3.5 as "official" version?

          Comment


          • #6
            Try this:

            http://www.vbulletin.com/forum/showt...+hosts+allowed
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X