Announcement

Collapse
No announcement yet.

Stuck On Step 1

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Stuck On Step 1

    I get this error on Step 1 of the upgrade (Going from 3.0.7) to 3.5 RC1

    Database error in vBulletin 3.0.7:
    Invalid SQL:
    ALTER TABLE session ADD languageid SMALLINT UNSIGNED NOT NULL;
    MySQL Error : Duplicate column name 'languageid'
    Error Number : 1060
    Date : Thursday, August 4th 2005 @ 02:05:31 PM
    Script : http://www.dvdcoversrus.co.uk/forums...0b1.php?step=1
    Referrer :
    IP Address : 81.178.118.67
    Username :
    Classname : vb_database

    Any Ideas?

  • #2
    This means that you have already tried running this upgrade before, or you have installed a hack that created a field that conflicts with 3.5.0. Did you install any hacks?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Just A Paypal subscription addon?

      Hmm is there anyway around this,

      Comment


      • #4
        Make a new backup of your database, then remove the 'languageid' field from the session table. Of course we cannot be responsible if this messes up a hack you've installed.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          So i take it that means i should re install 3.07 restore the backup i made then remove that line and start the upgrade again?

          Comment


          • #6
            No. I said make a new backup (just in case) and remove that field. Then try the upgrade again.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Oh

              I asked a m8 how to upgrade and was told to overwrite all files when it asked so no longer have access to the old 3.0.7 admin to remove any fields

              Oh well we live and learn looks like its the long way round for me then

              P.S Thx for help

              Comment


              • #8
                You do not need the 3.0.7 files to remove that field. You need to do this directly in the database, preferably with phpMyAdmin.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Oh i get you now

                  Thanks for your help will get onto it

                  Comment


                  • #10
                    Had a look in PHP admin

                    not really knowing what i am doing lol

                    But in the long structure list all i can see is language

                    Nothing saying lauguageid

                    Very strange

                    Comment


                    • #11
                      You can run this query, but we cannot be responsible if this messes up a hack or you have already run this upgrade once before:

                      ALTER TABLE 'session' DROP 'languageid';

                      Again, make a backup of your database first.
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        Thx again for help does not look like it wants to work

                        MySQL said:
                        #1064 - You have an error in your SQL syntax near ''session' DROP 'languageid'' at line 1

                        Thats when i run the query

                        So it seems the upgrade is not going to work and theres no going back so i guess only thing to do is re upload 3.0.7 and then restore the full backup i made to get back to normal

                        I would still like to upgrade to 3.5 as the paypal subscription script is not working correctly as it does not auto add people to the subscriptions so i thought putting 3.5 on would solve that now it supports subscriptions

                        But wanted to upgrade without losing the 50 subscribers we currently have really,

                        Comment


                        • #13
                          try removing the quotes. (I suck at this kind of stuff so I have no idea if it would help or not....)


                          But as Steve said, MAKE A BACKUP.

                          Comment


                          • #14
                            ok back to 3.0.7 all ok

                            Can anyone advise whats the best way to go about upgrading to 3.5, right now the site is relatively new with only 50 subscribers using that paypal subscription script we got from this site

                            So we would like to make the switch to 3.5 ASAP so we can use the built in Paypal subscription features

                            Will it ever be possible to upgrade with this hack installed and will 3.5 be able to add all the info into its own system?

                            Or should i remove the hack (not sure how) upgrade to 3.5 and then manually setup all the subscriptions again while there are few of them?

                            Sorry if this is in wrong section just would like abit of advice

                            Comment

                            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                            Working...
                            X