Announcement

Collapse
No announcement yet.

Avatar link showing instead of avatar

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts
    Sidewindr
    Member

  • Sidewindr
    replied
    Check all of your php files then .. there may be a stray character. A space or any other character after the ?> will also do the same thing.

    Leave a comment:

  • Xstreamist
    Member

  • Xstreamist
    replied
    Dang.. checked that out and no CR...
    Anyone got any other ideas?

    Leave a comment:

  • Sidewindr
    Member

  • Sidewindr
    replied
    a CR Is a Carridge Return .. it's essentially a newline .. the very last characters of your config.php file MUST be the ?> characters designating the end of the PHP statement.. anything after that will end up in the image data.

    Leave a comment:

  • Xstreamist
    Member

  • Xstreamist
    replied
    Sidewinder, can you describe how you fixed you problem a little more please?
    I am having the same problem and Skelp's solution does not fix it and I don't understand what you mean about the CR at the bottom of the config.php page. I checked my config.php page and don't see any CR... or is CR a short form for something? Any help is greatly appreciated from anyone.

    Leave a comment:

  • Sidewindr
    Member

  • Sidewindr
    replied
    Problem solved with the help of vbulletin support! Thanks guys you helped alot under tricky circumstances

    Problem was a CR at the bottom of the config.php file .. d'oh!!

    Leave a comment:

  • Sidewindr
    Member

  • Sidewindr
    replied
    My problem is not in any style or template.

    The problem is to do with either php or apache I think, the avatars are stored in the DB fine and can be uploaded into the DB fine however displaying them just will not work.

    The odd thing is that if I put in the URL to display the avatar (eg. http://www.vbulletin.com/forum/image...ine=1081621576) which is Zachery's on this forum I don't get an image instead I get a broken image in my browser (IE) or the url as text in Firefox. ..

    See http://www.ls1.com.au/forum/image.ph...ine=1132924331

    Why or what would be causing this? I am sure it's a php.ini setting that's doing it. The odd thing is that the data is being sent but there are 2 Content-Length lines in the Header presumably one from php and one from apache and they differ by 1 byte with the php one being the correct byte count and the apache one being 1 byte larger.

    Leave a comment:


  • Skelp
    replied
    Sidewindr, I had this problem too and mine was just like yours. Heres what fixed mine.
    Go to Style Manager, then in the drop down box beside any of the styles/templates you have select revert all templates. Now you have to delete the style you want ot use. If it is set as the default syle you need to change that but going to vbulletin options. In there select the Styles and languages option. In there reset the default template and save.
    Now go back to Style manager, and on the style that you were using and having the problem with click the drop down box and go down to delete.
    Now go to Download/Upload styles and reupload the style.
    I don't know how or why but this fixed my problem.

    Leave a comment:

  • Sidewindr
    Member

  • Sidewindr
    replied
    I too have this problem but the templates both have the correct avatarurl syntax. The thing is these avatars are being displayed as text as well in the user profile display.
    Sidewindr
    Member
    Last edited by Sidewindr; Fri 25 Nov '05, 5:56am.

    Leave a comment:


  • Creativ
    replied
    Woo I had this same problem. Lucky I didn't have to edit postbit_legecy as it has $post[ava, but not postbit. Wicked! Thank you!

    Leave a comment:

  • BNdotcom
    New Member

  • BNdotcom
    replied
    i found the templates issue and updated the " $avatarurl and change it to $post[avatarurl]" thank you 100times over.

    Leave a comment:

  • BNdotcom
    New Member

  • BNdotcom
    replied
    where do i find the post bit and post bit legacy files to upgrade/fix?

    same problem here with 2 of my 4 skins.

    Leave a comment:

  • Zachery
    Former vBulletin Support

  • Zachery
    replied
    Changes happen in major versions.. changes always happen... thats why it is a stable version. The stock style unmodified will always work which is the only one we support.

    Leave a comment:


  • Dys
    replied
    Below fix worked perfect and was very easy. I upgraded from 3.0.9 to 3.5.0

    Originally posted by Zachery
    Revert your postbit template

    or find
    $avatarurl and change it to $post[avatarurl]

    Leave a comment:

  • JamieB
    Senior Member

  • JamieB
    replied
    Yip that was one of my probs as well

    No disrespect to vB developers but why all the changes if its supposed to be a gold stable package

    Leave a comment:


  • Mask@ZK
    replied
    Originally posted by Zachery
    No files, vBulletins template system is not file based, all the templates are contained within the database

    AdminCP > Styles & Templates > Style Manager > Click on << >> > Find the postbit template group > Edit the postbit template, find $avatarurl and replace it with $post[avatarurl]

    Repeat for the postbit_legacy template.
    Like a Charm......

    Thanks You Mr. Zachery, You've saved me scratching at my head until a bald spot was formed from having all my hair eroded off....

    Leave a comment:

Loading...
Working...
X