Announcement

Collapse
No announcement yet.

Warning: Invalid argument...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Warning: Invalid argument...

    When I open my usercp this shows up at the top of the page. So far it hasn't affected anything, except for just showing up at the top of the page.

    Warning: Invalid argument supplied for foreach() in /includes/functions_user.php on line 50

  • #2
    The first thing I recommend is that you reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server.

    Next, create a new style and choose no parent style. This will force it to use the default templates. Then change to this style and view your forums with it. Do you have the same problem?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      I tried that, I had uploaded everything in Binary before, but I uploaded everything non-image as ASCII, the message still shows up though.

      Comment


      • #4
        What's the URL?
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          http://muramune.com/forums/usercp.php

          Comment


          • #6
            I don't see that, but then again I don't have an account. Please provide a test account.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Username: test
              Password: *deleted*
              Last edited by Troak; Fri 29 Jul '05, 11:27am.

              Comment


              • #8
                Line 50:
                foreach ($vbulletin->userinfo['forumpermissions'] AS $forumid => $perm)

                Is this an upgrade or a fresh install? I also don't see any forums listed. Do you have any forums?
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  This is a fresh install, I had a forum but deleted it and planned to add my own, but this error caught my eye first. Is the error caused by having no forums?

                  Edit: I made a forum and the error text did not so, I'm assuming that was the problem but I'll wait for your response.

                  Comment


                  • #10
                    Yes, since that line of code involved forum permissions and you had no forums, that was the cause of this problem.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Thank you for your help

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X