Announcement

Collapse
No announcement yet.

phpBB -> vB 3.5.0 RC1 Import SQL Errors

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • phpBB -> vB 3.5.0 RC1 Import SQL Errors

    I'm getting a bunch of SQL errors when I'm trying to use ImpEx to run initial checks.

    I get this when I run the Check and Update Database command first.

    moderator - importmoderatorid OK
    usergroup - importusergroupid OK
    ranks - importrankid OK
    poll - importpollid OK
    forum - importforumid OK
    forum - importcategoryid OK
    user - importuserid OK
    style - importstyleid OK
    thread - importthreadid OK
    post - importthreadid OK
    thread - importforumid OK
    smilie - importsmilieid OK
    pmtext - importpmid OK
    avatar - importavatarid OK
    customavatar - importcustomavatarid OK
    customprofilepic - importcustomprofilepicid OK
    post - importpostid OK
    attachment - importattachmentid OK
    pm - importpmid OK
    Warning: array_key_exists(): The second argument should be either an array or an object in /impex/ImpExData.php on line 342

    Warning: array_key_exists(): The second argument should be either an array or an object in /impex/ImpExData.php on line 342

    There seems to have been a slight problem with the database.
    Please try again by pressing the refresh button in your browser.
    An E-Mail has been dispatched to our Technical Staff, who you can also contact if the problem persists.
    We apologise for any inconvenience.
    Database error in vBulletin:ImpEx Target :

    Invalid SQL: ALTER TABLE `vb_usergroup` ADD `pmforwardmax` SMALLINT( 5 ) UNSIGNED DEFAULT '5' NOT NULL
    mysql error: Duplicate column name 'pmforwardmax'

    mysql error number: 1060
    Date: Friday 29th of July 2005 11:24:01 AM
    Any ideas what I'm doing wrong?

    This is a COMPLETELY new install, nothing moded in the code. I simply just installed vB 3.5.0 RC1 and I get these SQL errors. Any help is greatly appreciated!!! thank you =)

  • #2
    Sorry, I think I just found the answer here.

    Edit: I thought I had found it, but I tried running all those steps and still nothing.

    Any suggestions to how I get past this?
    Last edited by jdingman; Fri 29th Jul '05, 8:44am.

    Comment


    • #3
      Impex does not support 3.5 yet and wont until its stable.

      You would have to install 3.0.8,impex the data and then upgrade to 3.5 RC1.

      Comment


      • #4
        Ah perfect, thank you =)

        Comment


        • #5
          Ok, I installed 3.0.8 and am trying to do the import now, but it's giving me SQL errors.

          Warning: mysql_connect(): Access denied for user: '[email protected]' (Using password: NO) in /impex/db_mysql.php on line 98
          I have correctly ended the values as I show below:

          targetdatabasetype = mysql
          targetserver = localhost
          targetuser = username_vbusr
          targetpassword = 424k242jk4jkjpassword
          targetdatabase = usernae_vb
          targettableprefix = vb_
          But still I get that error. Any ideas what could be creating this?

          Comment


          • #6
            Have you got the correct details for the source database and have you changed source exists to true.

            Comment


            • #7
              Yes, I did both of those steps. All the variables are correct, but I'm still getting the same errors... I'm not sure what I'm doing wrong with it.

              Comment


              • #8
                I tried it one last time...and success!

                For those are having the same problem....here is my solution.


                Thinking it would be ok to remove the quotes on password and username, I was wrong. You must keep the quotes there on those two selected variables. Edit it DIRECTLY not deleting or adding anything. Only replace variables and you should have a successful import =)

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X