Announcement

Collapse
No announcement yet.

Upload of file failed for me as well

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Upload of file failed for me as well

    After upgrading from 3.0.7 to 3.5.0 Beta 4 files cannot be uploaded.

    Forum URL: http://rbrally.gamenavigator.ru/forum/
    Server is running in Safe Mode. Forum has temporary directory for uploads /home/www/rbrally.gamenavigator.ru/htdocs/forum/interim CHMOD'ed 777.

    Diagnostic results:
    file_uploads: On
    open_basedir: /home/www/rbrally.gamenavigator.ru/
    safe_mode: On
    upload_tmp_dir: No
    upload_max_filesize: 2.00 MB

    P.S. HELP!

  • #2
    First, you will not be able to store attachments in the file system. So if that is how you have this setup, then change it back to the database.

    Second, to get uploads to work you need to set "Upload In Safe Mode?" to 'Yes' and point the "Safe Mode Temp Directory" to :

    /home/www/rbrally.gamenavigator.ru/htdocs/forum/interim
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      That's exactly how it was set up in 3.0.7 and I didn't change anything. Strange, but it stopped working after upgrading...

      The attached file's temporary location (/tmp/phpzJ2In6) could not be found. The test cannot continue despite the fact that there is no upload_tmp_dir.
      Last edited by AZone; Mon 18 Jul '05, 9:13am.

      Comment


      • #4
        Then your server is using it's own /tmp directory. You or your host will need to create a /tmp directory off the root direcootry of the server and chmod it to 777. Then you'll need to edit php.ini and set the upload_tmp_dir to:

        /tmp
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          So, I need to have both Safe Mode Temp Directory and upload_tmp_dir?

          Comment


          • #6
            Yes.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              That's unfortunate - administrator of my host server is on vacation.

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X