Announcement

Collapse
No announcement yet.

add space between categories?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • add space between categories?

    How do I add white space between each category? Ive tried searching for tcat but it gives too many results. I need to know where to go and what to modify. thanks

  • #2
    Open the template 'FORUMHOME' and find this code:
    Code:
     <tr align="center">
    <td class="thead">&nbsp;</td>
    <td class="thead" width="100%" align="$stylevar[left]">$vbphrase[forum]</td>
    <td class="thead" width="175">$vbphrase[last_post]</td>
    <td class="thead">$vbphrase[threads]</td>
    <td class="thead">$vbphrase[posts]</td>
    <if condition="$vboptions['showmoderatorcolumn']">
    <td class="thead">$vbphrase[moderator]</td>
    </if>
    </tr>
    and delete that from the template.

    Save the template.

    Open the template 'forumhome_forumbit_level1_nopost' and find this code:
    Code:
    $childforumbits
    and above it, on a new line, add this code:
    Code:
     <tr align="center">
    <td class="thead" width="35">&nbsp;</td>
    <td class="thead" align="$stylevar[left]">$vbphrase[forum]</td>
    <td class="thead" width="235">$vbphrase[last_post]</td>
    <td class="thead" width="80">$vbphrase[threads]</td>
    <td class="thead" width="80">$vbphrase[posts]</td>
    <if condition="$vboptions['showmoderatorcolumn']">
    <td class="thead" width="125">$vbphrase[moderator]</td>
    </if>
    </tr>
    And save the template.

    Open the template 'FORUMHOME' and find this code:
    Code:
    <!-- main -->
    <table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="$stylevar[cellspacing]" border="0" width="100%" align="center">
    <thead>
    <if condition="$show['guest']">
    <!-- guest welcome message -->
    and replace it with this code:
    Code:
    <!-- guest welcome message -->
    <if condition="$show['guest']">
    <table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="$stylevar[cellspacing]" border="0" width="100%" align="center">
    <thead>
    and now find this code:
    Code:
     <!-- / guest welcome message -->
    </if>
    </thead>
    $forumbits
    and replace it with this code:
    Code:
     
    </thead>
    </table><br />
    </if>
    <!-- / guest welcome message -->
    $forumbits
    And now find this code:
    Code:
    <tbody>
    <tr>
    <td class="tfoot" align="center" colspan="<if condition="$vboptions['showmoderatorcolumn']">6<else />5</if>"><div class="smallfont"><strong>
    <a href="forumdisplay.php?$session[sessionurl]do=markread" rel="nofollow">$vbphrase[mark_forums_read]</a>
    <if condition="$vboptions['forumleaders']">&nbsp; &nbsp;
    <a href="showgroups.php?$session[sessionurl]" rel="nofollow">$vbphrase[view_forum_leaders]</a></if>
    </strong></div></td>
    </tr>
    </tbody>
    </table>
    <!-- /main -->
    and delete it.

    Now find this code:
    Code:
    </table>
    <br />
    <!-- end what's going on box -->
    and above this, on a new line (before the </table> one) add this code:
    Code:
    <tbody>
    <tr>
    <td class="thead" align="center" colspan="<if condition="$vboptions['showmoderatorcolumn']">6<else />5</if>"><div class="smallfont"><strong>
    <a href="forumdisplay.php?$session[sessionurl]do=markread" rel="nofollow">$vbphrase[mark_forums_read]</a>
    <if condition="$vboptions['forumleaders']">&nbsp; &nbsp;
    <a href="showgroups.php?$session[sessionurl]" rel="nofollow">$vbphrase[view_forum_leaders]</a></if>
    </strong></div></td>
    </tr>
    </tbody>
    And save the template 'FORUMHOME'.

    Now open the template 'forumhome_forumbit_level1_nopost' and on a new line, at the top of the template, before everything else, add this code:
    Code:
    <table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="$stylevar[cellspacing]" border="0" width="100%" align="center">
    and at the bottom of the template, after everything else, on a new line, add this code:
    Code:
    </table><br />
    And save the template.

    Now open the template 'forumhome_forumbit_level2_post' and find this code:
    Code:
    <td class="alt2">
    and replace it with this code:
    Code:
    <td class="alt2" width="35">
    and now find this code:
    Code:
     <td class="alt2" nowrap="nowrap">$forum[lastpostinfo]</td>
    <td class="alt1">$forum[threadcount]</td>
    <td class="alt2">$forum[replycount]</td>
    <if condition="$vboptions['showmoderatorcolumn']">
    <td class="alt1"><div class="smallfont">$forum[moderators]&nbsp;</div></td>
    </if>
    and replace it with this code:
    Code:
     <td class="alt2" nowrap="nowrap" width="235">$forum[lastpostinfo]</td>
    <td class="alt1" width="80">$forum[threadcount]</td>
    <td class="alt2" width="80">$forum[replycount]</td>
    <if condition="$vboptions['showmoderatorcolumn']">
    <td class="alt1" width="120"><div class="smallfont">$forum[moderators]&nbsp;</div></td>
    </if>
    Save the template and you're done.
    Last edited by Floris; Tue 5th Jul '05, 8:49pm.

    Comment


    • #3
      You know your templates! That's great. I've been thinking of putting white space in there, too, and you just saved me a few brain cells.
      ~ Life isn't always fair, but you can be. ~

      Comment


      • #4
        thanks that worked great, I just took step 12 and instead of doing a BR at the end I replaced that with a 10px tall colored div and it did exactly what I wanted

        Comment


        • #5
          Thank you very much for providing this information. Am using this.
          WNxWakko
          sigpic

          Comment


          • #6
            Hi, I was reading this and I can do it but do you just do it exact, and how do I know for instance I want 1,2,3 forums in the top sub forum then 4,5,6,7, under that sub catagory and so on. I want to break up my forum like your main one here. Doing this example here can give me the same results

            Comment


            • #7
              You ROCK Floris.....

              Comment


              • #8
                I will do that when I have spare week lol. Alot of things to edit. Sounds like an intreasting idea, but I think I will try it on a test skin before hand.
                http://www.motorsport-network.com
                http://www.motorsport-network.com/forums

                Comment


                • #9
                  Hi,

                  Does this procedure work with 3.5.0? I followed it to the letter and could not get it to work with the new version. Any ideas?

                  Regards,

                  Nathan

                  Comment


                  • #10
                    There might be some little changes, but compare the templates and it isn't hard to figure out. I believe the ones I use on my forum are the ones from 3.0 anyway.

                    Comment


                    • #11
                      So, I followed all of your directions Floris, and then my tables were off, so I went to this thread: http://www.vbulletin.com/forum/showthread.php?t=156777
                      and followed those directions.

                      It seems my tables are still off though: I have the forum column set to 50%, but the last post column is taking up most of the space available. Did i miss a step?

                      Here is my forumhome_forumbit_level1_nopost code:

                      Code:
                      <table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="$stylevar[cellspacing]" border="0" width="100%" align="center">
                      <tbody>
                          <tr>
                              <td class="tcat" colspan="<if condition="$vboptions[showmoderatorcolumn]">6<else />5</if>">
                                  <a style="float:$stylevar[right]" href="#top" onclick="return toggle_collapse('forumbit_$forumid')"><img id="collapseimg_forumbit_$forumid" src="$stylevar[imgdir_button]/collapse_tcat{$collapseimg_forumid}.gif" alt="" border="0" /></a>
                                  <a href="forumdisplay.php?$session[sessionurl]f=$forum[forumid]">$forum[title]</a>
                                  <if condition="$show['forumdescription']"><div class="smallfont">$forum[description]</div></if>
                                  <if condition="$show['subforums']"><div class="smallfont"><strong>$vbphrase[subforums]</strong>: $forum[subforums]</div></if>
                              </td>
                          </tr>
                      </tbody>
                      <if condition="$childforumbits">
                      <tbody id="collapseobj_forumbit_$forumid" style="{$collapseobj_forumid}">
                      <tr align="center">
                            <td class="thead" width="5%">&nbsp;</td>
                            <td class="thead" width="50%" align="$stylevar[left]">$vbphrase[forum]</td>
                            <td class="thead" width="25%">$vbphrase[last_post]</td>
                            <td class="thead" width="10%">$vbphrase[threads]</td>
                            <td class="thead" width="10%">$vbphrase[posts]</td>
                            <if condition="$vboptions['showmoderatorcolumn']">
                            <td class="thead" width="0%">$vbphrase[moderator]</td>
                            </if>
                          </tr>
                      $childforumbits
                      </tbody>
                      </if>
                      </table><br />
                      Last edited by JimmyWash; Wed 12th Oct '05, 11:46am.
                      My VB Version: 3.6.8
                      VB Blog: 1.01

                      Comment


                      • #12
                        Originally posted by StarshipTrooper
                        Hi,

                        Does this procedure work with 3.5.0? I followed it to the letter and could not get it to work with the new version. Any ideas?

                        Regards,

                        Nathan
                        Originally posted by JimmyWash
                        So, I followed all of your directions Floris, and then my tables were off, so I went to this thread: http://www.vbulletin.com/forum/showthread.php?t=156777
                        and followed those directions.

                        It seems my tables are still off though: I have the forum column set to 50%, but the last post column is taking up most of the space available. Did i miss a step?
                        I also can't get this to work on VB 3.5.0. Followed Floris's instructions bit by bit.

                        The Tips found in How To Put A Space Between Each Forum Category and after that this one : How To Change the Width of the Forum List Columns do not work perfectly either.

                        So I tried to come up with my own solution:

                        Change the Quick Tips on 'categorie spacing and widths'

                        It uses some spacer-gifs to align the tables. Don't know if it's a preferred solution, but it works.
                        If Floris is able to publish his solution that works in VB3.5.0 I am glad to try that out.
                        How much do you love XenForo?

                        Comment


                        • #13
                          cat spacing

                          cat spacing should be by default. what is the purpose of having all your categories smooshed together? All the time I've wasted trying to find a hack for 3.5?!?!?! Is not worth it. This wasn't an issue w/ 3.0.x. It was easy to get it going.

                          Comment


                          • #14
                            Originally posted by sitka
                            cat spacing should be by default. what is the purpose of having all your categories smooshed together? All the time I've wasted trying to find a hack for 3.5?!?!?! Is not worth it. This wasn't an issue w/ 3.0.x. It was easy to get it going.
                            I agree comlpetely! This should be an option via the admin cp. And on top of that, I followed the both sets of intrustctions(adding space between cats) written by the coders here and they both ended with slight errors. So there isnt even a sure way to do this from instructions given by vbulletin. Very annoying!
                            My VB Version: 3.6.8
                            VB Blog: 1.01

                            Comment


                            • #15
                              I got it to work, but I have a Introductions forum at the top (with no catagory) and it isn't separate from the catagory below it (as seen in screenshot below)
                              Attached Files

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X