Announcement

Collapse
No announcement yet.

Large File Attachment Problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Large File Attachment Problems

    Hi all, me again. Probably with another stupid question.

    I am haveing a problem with large attachments. I have configured the forum via the AdminCP to allow ZIP files of up to 35MB to be attached to posts. When I try to upload a file that large however, it sits for quite sometime then eventually goes to a screen saying "Page Not Found"

    I turned on the quick stats option and noticed two things:

    1. PHP Max upload size is 2MB
    2. Maximum Packet size is 1MB

    Do either of these need to be changed to allow for the larger files? If so, how do I change them? I am hosting my own server and it is a Windows install.

    Thanks in advance.

    Shan

  • #2
    Yes, php max upload would need to be changed as well as maximum packet size i think an apache varible must aslo be changed, max_execution time, if you search the forums you can find the anwsers.

    Comment


    • #3
      I did search the forums but I could not find specific info on how to get it working with Windows. There are several posts like yours that say change this and change that but I can find none that tell me where to change it. If it is ASP and MsSQL, I am all good, but I am new to MySQL and PHP and need a bit more hand-holding.

      Any help would be appreciated.

      Shan

      Comment


      • #4
        They are changes to ini's and config files. Ill take a few moments to look around and get back, Are you using apache or IIS? i know i can find the changes for apache, but im not sure about windows.

        Comment


        • #5
          IIS 6.0...but I can handle any of the changes needed there. Just need to know what I have to change in PHP and MySQL.

          Thanks for the help!

          Comment


          • #6
            In addition to the vB settings, the allowed size of the attachments depends on the PHP and MySQL configuration. You may need to check and changechange the upload size for both PHP and for MySQL. Note, you'll need to have root access to the server to do this (or have your host do it.) Make these changes to php.ini:

            upload_max_filesize = xM

            ..and my.cnf

            set-variable=max_allowed_packet=xM

            Also take a look at this:

            http://www.vbulletin.com/forum/showp...0&postcount=12
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Thanks Steve. Amazes me you guys don't charge more for vBulletin. The support alone would make me pay it.

              As always you guys rock!

              Comment


              • #8
                So, these two were not in my PHP.ini. Should I just add them?

                post_max_size
                memory_limit

                If so, do I use the same verbage? (ex. =50M)

                Shan

                Comment


                • #9
                  I've never used those settings myself. I assume you'd enter them in the same format as other php.ini settings.

                  Honestly, I'd be surpirsed if you ever got 35MB uploads to the forum to work on a consistent basis. Let us know how it turns out.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    So I got it set up so that now the AdminCP reports this:

                    PHP Maximum Upload Size 75M
                    PHP Memory Limit None
                    PHP Max Post Size 100M
                    MySQL Maximum Packet Size 100M

                    Then when I do my upload, I get this error:

                    Invalid SQL

                    INSERT INTO ATTACHMENT

                    Then it hangs.

                    Is this why you stated that you would be surprised to see if work consistently. Am I spinning my wheels here?

                    Shan

                    Comment


                    • #11
                      Sorry, I've given all the info I have on making large attachments work. Maybe someone else will have an idea.
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        Fair enough. Anyone else have anything they can add? Are large attachments just ineherntly unstable with VB? Would it matter if I used a directory structure rather than the DB?

                        Any ideas are appreciated.

                        Shan

                        Comment


                        • #13
                          The main problem as I see it is the time it would take for someone to upload or download a 35MB file. Not everyone has broadband.
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #14
                            If you enable attachments as files you will have a better chance at getting this to work.

                            Comment


                            • #15
                              I have no problems uploading 40MB files into the filesystem. I have found that having that large of files and / or large ammounts of files in the SQL database can cause severe slowdowns as well.

                              Comment

                              Loading...
                              Working...
                              X