Announcement

Collapse
No announcement yet.

Database errror

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Database errror

    I was installing vb3 RC4 and it wouldn't connect to my database.
    My vb 2.3.3 works fine with the same database though, so I'm a bit confused. This is what shows up:

    Step 2) Connect to the database

    ÿþ
    Attempting to attach to database


    Warning: mysql_errno(): supplied argument is not a valid MySQL-Link resource in e:\home\Default\excalipur.com\htdocs\test\upload\includes\db_mysql.php on line 140

    The database has failed to connect because you do not have permission to connect to the server. Please confirm the values entered in the 'includes/config.php' file.
    Last edited by Troak; Sun 8 Feb '04, 5:37pm.

  • #2
    The values in your config.php are not correct.

    Comment


    • #3
      Which values? I have edited the values several times and made sure that they are correct.

      Comment


      • #4
        You should contacnt your host, and ask them for your database name, database username and database password. We cannot give you these values.

        Comment


        • #5
          I'm using the same exact values as the values I use for my vb 2.3.3, which works perfectly fine.

          Comment


          • #6
            The error states:

            The database has failed to connect because you do not have permission to connect to the server. Please confirm the values entered in the 'includes/config.php' file.
            As far as I know it means what it says. I've never run across this error when the config.php info was correct and the user did have permission to access the database.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              I might need to recheck the values I used for my 2.3.3 and see if they are consistent.

              Comment


              • #8
                If you are using a new database, make sure the user has permissions to access that database as well.
                Translations provided by Google.

                Wayne Luke
                The Rabid Badger - a vBulletin Cloud demonstration site.
                vBulletin 5 API

                Comment


                • #9
                  Ok, this is quite wierd. I have the same values for my config.php in my vb 2.3.3 and my vb3, but vb3 doesnt work. I put the vb2.3.3 config file in the vb3 directory, and it connected.

                  Comment


                  • #10
                    Your missing some very important varibles from your config.php.

                    Comment


                    • #11
                      I added those in after installation.

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X