Announcement

Collapse
No announcement yet.

Attachment deletion button in usercp

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Attachment deletion button in usercp

    According to my members, the delete button disappears in their UserCP if the number of attachments uses less than 2 pages of space.

    I searched for a good 30 mins and found no mention of this, so I thought I'd ask! Is it a known bug? Any way to fix it?

  • #2
    I tried to duplicate this problem on my unhacked RC3 test forums and couldn't. The delete button still appears even with one page of attachments.

    Which version are you running and have you installed any hacks? Have you tried verifying this problem yourself?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Originally posted by Steve Machol
      I tried to duplicate this problem on my unhacked RC3 test forums and couldn't. The delete button still appears even with one page of attachments.

      Which version are you running and have you installed any hacks? Have you tried verifying this problem yourself?
      Running RC2, no 'hacks' aside from a few customizations to layout, etc. - no file changes. It doesn't seem to be an issue for anyone but registered members. I've had 2 now have the problem but neither of them could give me a screenshot (computer savvy forum, obviously). I will create a dummy account and see what I come up with.

      Thanks for trying, I'll get back to you if I can duplicate it.

      Comment


      • #4
        This bug may apply to you so try RC3 out.

        http://www.vbulletin.com/forum/bugs....iew&bugid=1750

        Comment


        • #5
          Originally posted by Freddie
          This bug may apply to you so try RC3 out.

          http://www.vbulletin.com/forum/bugs....iew&bugid=1750
          I am 98% certain I've already applied that fix, giving them the ability to delete them. They can now delete the attachments, the button just goes away after they get them down to one page. I'm waiting for gold to update again, they can deal with it in the meantime. Thanks though!

          Comment


          • #6
            Users at my forum are reporting the same problem. That the attachment delete button is not appearing in their options. Here is a supplied picture to illustrate the dilemma.

            http://www.shivasar.com/uploaded/image00.JPG

            any ideas?

            Comment


            • #7
              Which version are you running? This thread refers to a bug that was in the pre-release versions.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                Do the users have permission to edit posts in the forums that the attachment with missing delete boxes are located? Is the thread containing these attachments Open for posting?

                Comment


                • #9
                  Originally posted by Freddie Bingham
                  Is the thread containing these attachments Open for posting?
                  That may be the problem, because some of the attachments are over a year old, and we've wiped the forum post content within that time. But if that was the case shouldn't the mention of the attachments be gone?


                  Steve: I'm running the latest VBulletin, 3.0.1

                  Comment


                  • #10
                    No, it would show the attachments but not allow you to delete them because the thread is closed.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Originally posted by Merlin3649
                      That may be the problem, because some of the attachments are over a year old, and we've wiped the forum post content within that time. But if that was the case shouldn't the mention of the attachments be gone?


                      Steve: I'm running the latest VBulletin, 3.0.1
                      Yes if you delete a post, it should take the attachment with it but over time there may have been bugs that left orphan attachments behind. That being the case, the attachments you show in your screenshot have thread names listed so the threads are still there.

                      Comment


                      • #12
                        Originally posted by Freddie Bingham
                        Yes if you delete a post, it should take the attachment with it but over time there may have been bugs that left orphan attachments behind. That being the case, the attachments you show in your screenshot have thread names listed so the threads are still there.
                        ok, I doublechecked and you and Steve are right. The ones where no checkbox appears is a closed thread. However, why can't the user delete attachments from the thread that isn't closed? The ones with checkboxes. Also, is it possible for an admin to delete a user's attachments via the admin panel or does the admin have to manually edit the posts? I couldn't find an option in the admin panel.

                        Comment


                        • #13
                          What do you mean exactly? Are you saying even the attachments with the checkboxes aren't deleted when the user submits the page?

                          Comment


                          • #14
                            Originally posted by Freddie Bingham
                            What do you mean exactly? Are you saying even the attachments with the checkboxes aren't deleted when the user submits the page?
                            yes, there is no delete option even available for the user.

                            Comment


                            • #15
                              I'll see why the button is missing but maybe these two options will also be helpful to you. They are in the Message Attachment options section.

                              Allow Deletion of Attachments in Closed Threads
                              Allow Deletion of Attachments Beyond Edit Time Limit

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X