Announcement

Collapse
No announcement yet.

Just about to upgrade but first

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Just about to upgrade but first

    Next, you should delete all vBulletin 2 files, including PHP, CSS and style files, along with any images. You should then upload the contents of the 'upload' folder to your server.

    Wont i lose all my members and posts by doing this !!!!!!!!!


    do i select all the files and delete them off my server !!


    Help

  • #2
    Hi there, the files is what pulls the data from the stored things in your database and visualizes it into your browser.

    The database are not the .php files, it is on a different location outside the html directory.

    All your members, private messages, etc, are stored the database. So you will not loose those.

    If you have doubts, but even if you don't have any: MAKE A BACKUP OF THE FILES AND THE DATABASE before you do anything. Just to be sure - and so you can restore if things go wrong.

    You can delete all the forum files, images, etc. and then upload the version 3 things and run the upgrade.php script which will guide you through the upgrade procedure.

    The upgrade script will update the database to work properly with the new version 3 files. Without loosing members, PM's, etc.

    I hope this explains it

    If you have more questions, feel free to ask.

    Comment


    • #3
      so do i delete everything except httpdocs folder from my server

      Comment


      • #4
        Hi again,

        If you have installed the vBulletin forums into the directory:

        http_docs/forums/

        then delete the content of the folder forums/*

        if you have vBulletin installed in the root of the http_docs/ folder,
        then delete the content of the folder http_docs/*

        Do not delete the folder http_docs/ itself.

        If you have other non vBulletin files on your server, like a store, mail program, gallery .. then don't delete those files, just the vBulletin installation.

        Comment


        • #5
          I have done this uploaded all of VB3

          Gone to install/upgrade.php and i get this page


          There seems to have been a slight problem with the database.
          Please try again by pressing the refresh button in your browser.

          An E-Mail has been dispatched to our Technical Staff, who you can also contact if the problem persists.

          We apologise for any inconvenience.


          Why

          Help

          I can run install.php but dont i want to upgrade to keep memebers etc

          Many thanx
          postamble();
          Last edited by Gaz.t; Fri 30 Jan '04, 7:02am.

          Comment


          • #6
            <html><head><title> Database Error</title><style type="text/css"><!--.error { font: 11px tahoma, verdana, arial, sans-serif; }--></style></head>
            <body></table></td></tr></table></form>
            <blockquote><p class="error">&nbsp;</p><p class="error"><b>There seems to have been a slight problem with the database.</b><br />
            Please try again by pressing the <a href="javascript:window.location=window.location;">refresh</a> button in your browser.</p><p class="error">An E-Mail has been dispatched to our <a href="<A href="mailto:[email protected]">Technical">mailto:[email protected]">Technical Staff</a>, who you can also contact if the problem persists.</p><p class="error">We apologise for any inconvenience.</p></blockquote>

            <!--
            Database error in vBulletin :

            Link-ID == false, connect failed
            mysql error:

            mysql error number: 0

            Date: Friday 30th of January 2004 04:00:35 PM
            Script: http://www.gsmforums.com/install/upgrade.php
            Referer:
            IP Address: 80.5.160.6
            -->

            </body></html>

            Comment


            • #7
              Did you edit the config.php file?
              vBulletin v3.8.0's Implementation of Google Adsense Should Be Avoided At All Costs - Do Your Own Adsense Implementation

              Comment


              • #8
                yes but im not that sure i have done it correct

                Comment


                • #9
                  Make sure the details to the mysql database are correct.

                  If you are upgrading, then use the details from the config.php from version 2 and copy/paste those into the config.php details of version 3.

                  Like

                  server host: localhost
                  then goto includes/config.php and set set host to localhost too
                  ..etc.

                  if config.php is called config.php.new
                  then rename it to config.php first

                  Comment


                  • #10
                    Originally posted by floris
                    If you are upgrading, then use the details from the config.php from version 2 and copy/paste those into the config.php details of version 3.
                    He was instructed to delete those files. I can't understand why the instructions ask anyone to delete the files. I would suggest a new directory be created.

                    I also question how he made his database backup.

                    Comment


                    • #11
                      He was also instructed to make a backup, this includes the config.php file

                      But besides that, you can assume that a person knows the details to the mysql host,database name and user/pass that go along with it. The rest are just settings you have to go through.

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X