No announcement yet.

WebTV user can't post

  • Filter
  • Time
  • Show
Clear All
new posts

  • WebTV user can't post

    Just upgraded one of our boards to Release Candidate and one of our moderators is complaining they can't post. They kindly got back to me with some pretty decent information... I hope maybe someone can help fix this problem. It seems to be a bug, even though devs have said these WebTV have all been fixed now in RC2.

    I checked the Client Version, and it says
    it's " 2.8.1 External NonDebug"

    Unfortunately, I can't do anything at all in regard to upgrades. I'm
    stuck with with whatever the current browser version is. And I don't
    have the alternative of using a computer.

    I had this problem once before, and they had to change something to
    allow me to post. The "send" button on the email contact works, as did
    the "save changes" button in the user CP under Edit Options. And I was
    able to log in okay. So whatever is different in those buttons, and the
    ones that don't work (reply, or sending PM's or saving editing changes)
    might provide a clue.

    I don't get an error message. With WebTV, we don't have a cursor like on
    computers. It outlines the desired link/button with a yellow box. When
    we click on it, the box turns green, then it does whatever it's supposed
    to do. With the buttons that aren't working, when I clck, it does
    nothing. The box blinks, then stays yellow. This indicates script
    incompatibility. Whatever code is attached to the button doesn't work
    with WebTV. It might be some recent type of javascript (WebTV is only
    compatible with javascript up to a certain level, and we're not
    compatible with Java at all. I can't view Java Applets on this thing,
    for example).

    I have been able to log in (after clearing cookies), and send changes to the user CP, as well as send this form. But I can't reply (in any of the formats), send a PM, or edit, as noted above. So whatever is different in the submission of the latter functions from the former is what's causing the problem.

    I hope the info is of some help.

    FYI... we upgraded from beta 5 to RC2 so changes from those two stages have affected this WebTV user.

  • #2
    Can you ask him what sort of box he see's?

    Is it the advanced bbcode editor or just textarea?
    Scott MacVicar

    My Blog | Twitter


    • #3
      Hi Scott,

      Here's his response:

      Are you referring to the quick reply box, or the regular reply box? The
      Quick looks like it's just test area; a lot like the old one. The
      regular reply looks similar to the old one as well, with a section to
      choose "show signature", etc. Does that help?

      Oh, and I don't know if it helps, but I can click on the blue "reply"
      and "edit" buttons to get to those respective screens, but can't submit
      anything when I'm there. So I can't actually post the reply, or save the
      changes in the edit. I also can't delete an individual post this way,

      I haven't tried anything in the admin menu at the bottom of the threads
      (move thread, delete thread, etc.). Maybe I should find one of the
      garbage threads we closed a few days ago, and test it there. (Somethig
      that won't be missed.)

      Let me know if you need anything else from him. We're keen to help you resolve these WebTV issues before you release vb3 gold.


      • #4
        Yeah, this is all similar to what I'm hearing, except that my user doesn't know a lot about computers of any kind... but he's giving me about the same information.


        • #5
          Same here.

          My user is using "web tv plus" and says he "was able to scroll up and down and type my post but when I clicked on submit nothing happened."

          I don't know how to ask him specifically to give a more precise version or if that's necessary ?
          Last edited by boatdesign; Sat 10 Jan '04, 11:59pm.
          Boat Design & Boat Building Forums


          • #6
            there's a web tv emulator available.

            google it.



            • #7
              I just downloaded the emulator from

              I find that both on my own forum and on this forum I can login fine, but the submit and preview buttons on the new post or reply forms do not do anything - nothing posts and nothing happens when you hit them.

              There are tons of errors dealing with tag definitions that web tv doesn't support, but I don't see the one that is stopping the form from submitting.
              Boat Design & Boat Building Forums


              • #8
                I'm sure you're already aware of this but our user thought the following information might be helpful:

                This site might provide some helpful info into fixing the WebTV/MSNTV
                (they're the same thing) problem:


                I hope it helps.


                • #9
                  Is it the advanced bbcode editor or just textarea?
                  I changed my webtv user's preferenced from the enhanced editor to the standard editor and there was no change for them - he still can login but cannot submit a new reply or a new thread - the submit button for those forms does not function.
                  Boat Design & Boat Building Forums


                  • #10
                    I have the same problem with all of my web-tv users. The submit button does not work in new thread, post a repley, or in private messages.


                    • #11
                      It seems a number of us have this same problem so I posted it as a bug in the bugtracker at in hopes that it's resolved by RC3 if there isn't a solution before that time.
                      Boat Design & Boat Building Forums


                      • #12
                        Originally posted by boatdesign
                        It seems a number of us have this same problem so I posted it as a bug in the bugtracker at in hopes that it's resolved by RC3 if there isn't a solution before that time.
                        Excellent. Let's hope they solve this soon.


                        • #13
                          Thanks to the solution posted by Kier, my newthread and postreply both work now with the emulator

                          I didn't quite get the quick reply to work yet but it could be something I missed and that's not as essential.

                          Thanks Kier.
                          Boat Design & Boat Building Forums


                          • #14

                            It worked here, thanks ya'll!


                            • #15
                              I tried applying the code with the else statements and it stopped everyone from replying or posting a new thread. Any chance of someone letting me see the few lines of related code with the fix so I too can apply it? I don't really want to have to wait until the next RC is out for this.


                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.