Announcement

Collapse
No announcement yet.

Can't upload more than 3 megs! What gives?!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't upload more than 3 megs! What gives?!

    I think that if you run a search on this board about 'memory_limit' and 'max_execution_time', one of my threads will show up

    Here are my settings before I continue:

    Server Type WINNT / PHP v4.2.2
    File Uploads = On
    MySQL v3.23.54-nt
    PHP Maximum Upload Size 80M
    PHP Max Post Size 80M
    PHP Memory Limit N/A (even though it's set to 80M in the php.ini)
    MySQL Maximum Packet Size 64.00 MB
    max_execution_time = 7200 (2 hours)

    I tried uploading by increments such as 500K files, 1meg file, 2 meg file and I even went for a 2.94meg file. All of these worked like a charm when I uploaded them.

    However, when I tried to upload a simple 3meg or a 4meg file, I would see the page go to a 404 "The page cannot be displayed". I just increased the file weight by merely a meg and it's messing up. I tried everything and it looks like it's not working.

    I also have to say that I havent seen a site out there that is using vB the way Im planning to use it - for premium member videos where subscribed members can come and download fairly big video files ranging from 5megs to 30-40 megs. If I can't upload a small 5meg video file, how the hell am I gonna upload something bigger if I need to in the near future.

    Then again, I do kick myself in the head now telling myself that it's never too great to 'upload' big file via HTTP. It's never the best way to do it.

    If there's a vB staff person that can shine some light on this for me, I would really appreciate it. Looks like I might have to rethink how I'm going to 'protect' these videos for members only.

    Cheers!

  • #2
    Same problem still me,but still no solution find.I try everything (eva2000 suggestions) but still same.

    Same me....asp or http upload is no problem but php is problem,my server 1MB and up is problem...

    Comment


    • #3
      Originally posted by btekcan
      Same problem still me,but still no solution find.I try everything (eva2000 suggestions) but still same.

      Same me....asp or http upload is no problem but php is problem,my server 1MB and up is problem...
      Well, now I have to rethink on how I'm gonna put these videos up all by being 'protected'. I can't upload them, that's for sure.

      Any suggestions?

      Comment


      • #4
        take a look at how the ACP is protected


        regardless of any file in the ACP it all forces you to login.

        you might need MySQL 4.x for such large files though

        Comment


        • #5
          My host said he upped the maximum upload limit to 10 MB but it still shows this in the Admin CP:

          PHP Maximum Upload Size = 2M

          Shouldn't that say 10 MB?
          vBulletin - Sometimes, I'm just like, Wow, and then I'm like, Whoa, and then I'm like, Damn.

          vBulletin.org's ol' Moderator

          I have a lifetime terrorist hunting permit - #091101

          chmod a+x /bin/laden -- Allows anyone the permission to execute /bin/laden

          Comment


          • #6
            What does phpinfo show? Also the maximun upload size depends on the max_allowed_packet size in MySQL too.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              i know this sounds stupid to ask, but did your host restart apache?

              Comment


              • #8
                Originally posted by Steve Machol
                What does phpinfo show? Also the maximun upload size depends on the max_allowed_packet size in MySQL too.
                phpinfo show 2 MB also

                max_allowed_packet shows 1.00 MB in the Admin CP

                Can you tell me what I need to have him set? And he needs to restart Apache, right?
                vBulletin - Sometimes, I'm just like, Wow, and then I'm like, Whoa, and then I'm like, Damn.

                vBulletin.org's ol' Moderator

                I have a lifetime terrorist hunting permit - #091101

                chmod a+x /bin/laden -- Allows anyone the permission to execute /bin/laden

                Comment


                • #9
                  yes for changes to take place apache must be restarted

                  Comment


                  • #10
                    What about the settings, though?
                    vBulletin - Sometimes, I'm just like, Wow, and then I'm like, Whoa, and then I'm like, Damn.

                    vBulletin.org's ol' Moderator

                    I have a lifetime terrorist hunting permit - #091101

                    chmod a+x /bin/laden -- Allows anyone the permission to execute /bin/laden

                    Comment


                    • #11
                      i suggest waiting for Steve to reply my apahce configuration is limited ^^

                      Comment


                      • #12
                        There are several php.ini settings that affect file uploads..

                        upload_max_filesize - Largest size of a file to accept.
                        post_max_size - Must be larger than upload_max_filesize.
                        memory_limit - Should be larger than post_max_size

                        It is also possible for apache to be set to reject posts of a certain size or greater. I believe, if memory serves me correctly the directive LimitRequestBody which can be found in your httpd.conf file.

                        Lastly, regarding MySQL, you must also have the variable max_allowed_packet set to a value larger than your upload_max_filesize directive. If you are still experiencing problems with large uploads you may want to contact your host.

                        FWIW, I'm working on a upload/download manager for vB that uses vB templates, editors, etc. Won't be done for a few more weeks yet though.
                        Boardoo.com - Hosting, Software, WHMCS Addons, and whole lot more.
                        Featuring vBLink :: The vBulletin Integration Suite for WHMCS

                        Comment


                        • #13
                          Originally posted by TheHideoutGuy
                          There are several php.ini settings that affect file uploads..

                          upload_max_filesize - Largest size of a file to accept.
                          post_max_size - Must be larger than upload_max_filesize.
                          memory_limit - Should be larger than post_max_size

                          It is also possible for apache to be set to reject posts of a certain size or greater. I believe, if memory serves me correctly the directive LimitRequestBody which can be found in your httpd.conf file.

                          Lastly, regarding MySQL, you must also have the variable max_allowed_packet set to a value larger than your upload_max_filesize directive. If you are still experiencing problems with large uploads you may want to contact your host.

                          FWIW, I'm working on a upload/download manager for vB that uses vB templates, editors, etc. Won't be done for a few more weeks yet though.
                          Can you tell me what I should have him set that stuff at to be able to get the PHP Maximum Upload Size from the curent 2 MB to 10 MB? And what files all those settings are in? Are they all in the php.ini file? I have never messed with any of this stuff and neither has he, it seems.

                          If I have a list of exactly what he should do, then maybe he won't accidentally mess it up and we can get the changes made smoothly.
                          vBulletin - Sometimes, I'm just like, Wow, and then I'm like, Whoa, and then I'm like, Damn.

                          vBulletin.org's ol' Moderator

                          I have a lifetime terrorist hunting permit - #091101

                          chmod a+x /bin/laden -- Allows anyone the permission to execute /bin/laden

                          Comment


                          • #14
                            My recommendations...

                            Originally posted by Boofo
                            Can you tell me what I should have him set that stuff at to be able to get the PHP Maximum Upload Size from the curent 2 MB to 10 MB? And what files all those settings are in? Are they all in the php.ini file? I have never messed with any of this stuff and neither has he, it seems.

                            If I have a list of exactly what he should do, then maybe he won't accidentally mess it up and we can get the changes made smoothly.
                            That's a very good question.. I would recommend that you use the following settings:

                            PHP: php.ini
                            upload_max_filesize = 10M
                            post_max_size = 11M #(Note that it is 1 MB larger so there is room in a POST request for more than a 10MB file)
                            memory_limit=19MB #(This allows for a 11 MB post, while still giving php 8 MB of available RAM to run in, which is the php default)

                            MySQL: my.cnf or my.ini (win32)
                            max_allowed_packet = 16M #(Max allowed by MySQL)

                            Apache: httpd.conf
                            <LimitExcept>
                            LimitRequestBody 16777216 #(16 MB Max POST/GET size)
                            </LimitExcept>

                            I hope that is what you need to get you up and running!
                            Boardoo.com - Hosting, Software, WHMCS Addons, and whole lot more.
                            Featuring vBLink :: The vBulletin Integration Suite for WHMCS

                            Comment


                            • #15
                              Thank you, sir.

                              Right now the php post max size is set to 55 MB.

                              What should this be for that? And do any of the others settings need to be changed for this?

                              Apache: httpd.conf
                              <LimitExcept>
                              LimitRequestBody 16777216 #(16 MB Max POST/GET size)
                              </LimitExcept>
                              vBulletin - Sometimes, I'm just like, Wow, and then I'm like, Whoa, and then I'm like, Damn.

                              vBulletin.org's ol' Moderator

                              I have a lifetime terrorist hunting permit - #091101

                              chmod a+x /bin/laden -- Allows anyone the permission to execute /bin/laden

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X