Announcement

Collapse
No announcement yet.

Uploading Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • GamerzWorld
    replied
    Fixed!

    problem was because webserver cannot access tmp (even if it's chmod 777) because the upper dir (was on chmod 700)

    so the solution is..

    chmod 701 ~
    mkdir tmp
    chmod 777 ~/tmp

    simple eh...

    thanks all for the help

    Leave a comment:


  • Mike Sullivan
    replied
    I really hate open_basedir... In this situation, it'd probably be best to contact your host and ask them to set your upload_tmp_dir to a directory within whatever open_basedir restriction they have (in this case, the tmp directory you created should work).

    Leave a comment:


  • GamerzWorld
    replied
    bump up need it fixed

    Leave a comment:


  • GamerzWorld
    replied
    Hello :/

    Leave a comment:


  • GamerzWorld
    replied
    Can any Dev Help?

    Leave a comment:


  • poolking
    replied
    Originally posted by GamerzWorld
    I know steve didnt say that but if he can think of no solution and no one else is posting then i cant fix problem
    One of the devs could help.

    Leave a comment:


  • GamerzWorld
    replied
    I know steve didnt say that but if he can think of no solution and no one else is posting then i cant fix problem

    Leave a comment:


  • poolking
    replied
    Originally posted by GamerzWorld
    So theres no fix :/
    Steve didn't say that.

    Leave a comment:


  • GamerzWorld
    replied
    So theres no fix :/

    Leave a comment:


  • Steve Machol
    replied
    Well the templates seem okay now. Sorry but this one has me stumped. As far as I can see there should be no reason for the errors you are getting.

    Leave a comment:


  • GamerzWorld
    replied
    I did a search for templates for "attach" and only a custom template is in red.
    I reverted those in "find updated templates" but doesn't seem to do the job.

    ps. I have enabled full access to the admin cp.



    Originally posted by Steve Machol
    Well I duplicate the problem but it appears that you are not running the default templates - particularly the one controlling the attschment screen. Unfortunately you did not provide full access to the Admin CP to check this out.

    I suggest you revert all templates. You should also run 'Find Updated Templates' functions and revery any it finds.


    I suggest reverting

    Leave a comment:


  • Steve Machol
    replied
    Well I duplicate the problem but it appears that you are not running the default templates - particularly the one controlling the attschment screen. Unfortunately you did not provide full access to the Admin CP to check this out.

    I suggest you revert all templates. You should also run 'Find Updated Templates' functions and revery any it finds.


    I suggest reverting

    Leave a comment:


  • GamerzWorld
    replied
    PM'ed

    what I did...

    in vb options
    Safe Mode = On
    upload dir = /home/users/gamerzwo/tmp

    in my shell account
    made tmp dir right under my home dir
    so the path is
    /home/users/gamerzwo/tmp
    then chmod 777 tmp


    and I get this error
    Warning: move_uploaded_file(/home/users/gamerzwo/tmp/a3457c8ca2205d2ec3b27c75dd4e1241): failed to open stream: Permission denied in /home/www/gamerzwo/forum/includes/functions_file.php on line 225

    Warning: move_uploaded_file(): Unable to move '/tmp/phpbAk5vY' to '/home/users/gamerzwo/tmp/a3457c8ca2205d2ec3b27c75dd4e1241' in /home/www/gamerzwo/forum/includes/functions_file.php on line 225

    Warning: filesize(): Stat failed for /home/users/gamerzwo/tmp/a3457c8ca2205d2ec3b27c75dd4e1241 (errno=13 - Permission denied) in /home/www/gamerzwo/forum/includes/functions_file.php on line 231
    Originally posted by Steve Machol
    Please PM me access to your Admin CP and shell. Be sure to include an example of exactly what you are doing and the complete error message you are getting.

    Leave a comment:


  • Steve Machol
    replied
    Please PM me access to your Admin CP and shell. Be sure to include an example of exactly what you are doing and the complete error message you are getting.

    Leave a comment:


  • GamerzWorld
    replied
    yup done that... but it's giving me those 3 errors

    [[email protected] ~/tmp]$ pwd
    /home/users/gamerzwo/tmp
    [[email protected] ~/tmp]$ ls -al
    total 8
    drwxrwxrwx 2 gamerzwo gamerzwo 4096 Jan 8 23:25 .


    Originally posted by Steve Machol
    Try this. Log into the shell and run these in succession:

    mkdir tmp
    chmod 777 tmp
    cd tmp
    pwd

    Supposedly this should give you:

    /home/users/gamerzwo/tmp

    Use that for the safe mode temp directory setting. Note also you MUST have safe mode set to 'Yes'.

    Leave a comment:

Related Topics

Collapse

Working...
X