Announcement

Collapse
No announcement yet.

Stalls on Step 2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Stalls on Step 2

    New to vB.

    Using on Debian Linux:
    vB v3.0.0 RC1
    mysql-server v3.23.49
    php v4.1.2
    apache v1.3.26
    Created a mysql database via mysqladmin. Created a user. Grants all on db to user. Flush db.

    Edited the includes/config.php.

    Moved files to appropriate path - owned by root.root, all files/directories as 755 (is this right?)

    During install/install.php I move to Step 2. Found database, click to Next Step. Nothing.

    Dropped the database, ensured user has privileges to create database. Again, on Step 2 - 'Database creation successful', click to Next Step. Nothing.

    Searched in mysql.err - no errors.

    Searched in mysql.log, after the 'CREATE DATABASE' statement (confirmed via mysql, empty db does exist), no other connections in the log. Appears the Next Step (above) is not getting to the db.

    Attempted all steps above, including 'cp -a' of the source tar.gz to target, but connecting to the db as 'root'. Same.

    Searched this forum without success. Searched attached documentation as well as the online Manual also without success.

    My guess - permissions on the filesystem, or logic in the code. Database should have something in the logs if that was the problem. Apache is running as user 'nobody'.

    Help?

  • #2
    Tested as 777

    Update.

    Stalled in the same spot after changing permissions on all files to 777. `chmod -R 777 dir`

    Comment


    • #3
      Nother update.

      On Step 2 - when database already exists and following the link to 'empty' the database goes to Step 3... the Reset Database links do not appear to work as well.

      Clicking on 'Yes' does not hit the database (checked via mysql.log) and does nothing else. Clicking on 'No', same.

      Thanks.

      Comment


      • #4
        Hmm. This is starting to sound to me like you don't have a mysql user assigned to that database. Have you tried installing some other small script there first and seeing if the same thing happens?
        "I can't seem to bring myself to say, 'Well, I guess I'll be toddling along.'
        It isn't that I can't toddle. It's that I can't guess I'll toddle."

        --Robert Benchley (1889-1945)

        Comment


        • #5
          Originally posted by welo
          Hmm. This is starting to sound to me like you don't have a mysql user assigned to that database. Have you tried installing some other small script there first and seeing if the same thing happens?
          Hum... don't think thats it. I tried running as the mysql 'root' user - nothing. As well, if no db existed (prior to starting the install/install.php) it is created in Step 2 - but still not able to move to Step 3. As well - if it was permissions, something would have been in the logs.

          But I did take your suggestion and tried to manually create a table object as 'root' in the newly created db (above) - worked. Ditto on the user within includes/config.php. This was done via 'mysql' terminal.

          Thanks for the suggestion though.

          Comment


          • #6
            use latest php thats an old version

            Comment


            • #7
              Originally posted by Exero
              use latest php thats an old version
              Per http://www.vbulletin.com/features/index.html (though I recognize that this may be for the 'stable' release of vB), php must have, as a minium, v4.0.4 and mysql v3.23.33.

              I'll give v2.33 of vB a try tomorrow.

              BTW - latest release for open source projects, by no ways means stable or better. Though I will upgrade as needed.

              Comment


              • #8
                v2.33 works.

                I installed v2.33 successfully - using same db parameters. Perhaps there are version issues with v3.0.0 RC1?

                I will attempt an upgrade.

                Comment


                • #9
                  Originally posted by Exero
                  use latest php thats an old version
                  Debian people rarely use the latest version of anything on sheer principle .

                  I was about to say running the script as root might be providing a conflict due to the ownership, but if you got 2.3.3 running that might not be it. Even so, it could be worth setting it up from another user and seeing what happens. I've seen some strange stuff from root-owned installations of stuff before.
                  "I can't seem to bring myself to say, 'Well, I guess I'll be toddling along.'
                  It isn't that I can't toddle. It's that I can't guess I'll toddle."

                  --Robert Benchley (1889-1945)

                  Comment


                  • #10
                    Originally posted by welo
                    Debian people rarely use the latest version of anything on sheer principle .
                    Well... for good reason.

                    Its called 'stable' for a reason.

                    I was about to say running the script as root might be providing a conflict due to the ownership, but if you got 2.3.3 running that might not be it. Even so, it could be worth setting it up from another user and seeing what happens. I've seen some strange stuff from root-owned installations of stuff before.
                    And running the scripts as the Apache user 'nobody' is a security risk. Seems like vB should have a script to clean up permissions? Using 777 or 755 does not seem like a good idea (ie - security, managability, etc) on all files and directories (very Windows-centric IMHO).

                    Thanks.

                    Comment


                    • #11
                      Upgrade to v3 RC1

                      Okay - tried to upgrade to v3 RC1 from v2.33.

                      Stalls on the upgrade1.php - entering in the Customer Number and pressing Enter does nothing.

                      No errors in mysql.err.

                      Help? Back to where I started.

                      Comment


                      • #12
                        Start with upgrade.php, not upgrade1.php.
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment


                        • #13
                          Originally posted by Steve Machol
                          Start with upgrade.php, not upgrade1.php.
                          I did. Just stating where the 'stall' happened.

                          Comment


                          • #14
                            Make sure you are using the exact customer number for this zip file.
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment


                            • #15
                              Man, if I didn't have so much to do today I'd be real tempted to reimage my local Fedora box and install Debian just to see if I could re-create these issues. It's starting to sound like this is some kind of Debian-created Apache conflict due to some special security setting or whatever. You sure don't see Debian being used for web servers very often nowadays. I would seriously consider upgrading PHP though and see if that helps.
                              "I can't seem to bring myself to say, 'Well, I guess I'll be toddling along.'
                              It isn't that I can't toddle. It's that I can't guess I'll toddle."

                              --Robert Benchley (1889-1945)

                              Comment

                              Loading...
                              Working...
                              X