Announcement

Collapse
No announcement yet.

What do I need to make the archive work?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    With above mentioned both work now, for Apache 1.3.x with PHP as module and with Apache 1.3.x with PHP as CGI.
    Tested on big forums.
    http://www.mcseboard.de/images/buttons/lastpost.gif www.MCSEboard.de
    German Windows Server & IT Pro Community dedicated to Windows Client & Server Systems. MVPs inside

    Comment


    • #32
      If you have apache as a module, the archive does work on 1.3. That is what my server uses and you can see the archive works on my forum.

      From what I understand the Acceptpathinfo command is always ON on 1.3, you can't control it and so there is no option for it.

      Comment


      • #33
        Originally posted by Milez
        OK after some more Googling I finally got it to work. Here is the solution.

        First make sure your running Apache 2.0 or better and edit your httpd.conf file. Find the Directory containers listing pertaining to your website. It will look something like this:

        <Directory "/usr/local/apache/othersites/yourwebsite/">
        Options Indexes FollowSymLinks MultiViews
        AllowOverride AuthConfig FileInfo
        Order allow,deny
        Allow from all
        </Directory>

        The important line is:
        AllowOverride AuthConfig FileInfo

        Without the 'AllowOverride FileInfo' directive set you will not be able to Override your settings in an .htaccess file. So that leads us to the final step. Make a .htaccess file in your vB/archive directory and put this line in it:

        AcceptPathInfo On

        The archive system with VB3 should now work properly.
        Anybody know where to find this httpd.conf file? I have looked in ftp and can't find it. I have SSH ability, but don;t know the commands to look for such a file.
        in SSH. I see this
        /kunden/homepages/28/d98287039/htdocs >
        http://www.denzoforums.com/forum/archive/index.php = error 500

        Anybody?
        Thanks
        Dave
        Last edited by Denzo; Fri 23rd Apr '04, 1:50pm.

        Comment


        • #34
          Any translations for this fix from German to English?

          Comment


          • #35
            Please read the thread, I translated all...

            Please note that it is only intended for vB3.0.0 and only for PHP-CGI.

            There exists a version for 3.0.1 on vb-g.com though
            http://www.mcseboard.de/images/buttons/lastpost.gif www.MCSEboard.de
            German Windows Server & IT Pro Community dedicated to Windows Client & Server Systems. MVPs inside

            Comment


            • #36
              Originally posted by Thomas P
              Please read the thread, I translated all...

              Please note that it is only intended for vB3.0.0 and only for PHP-CGI.

              There exists a version for 3.0.1 on vb-g.com though
              Where???? There is no site

              Comment


              • #37
                Originally posted by Elbonian
                Since I don't like .htaccess files, and since the Apache manual warns against them (use them only as a last resort), I wanted to ensure that everybody noticed that you can fix this in your Apache configuration as part of your directory definitions, thusly:
                Code:
                <Directory "{directory path to forums}/archive">
                		Options Indexes Includes FollowSymLinks
                 
                		AllowOverride None
                		Allow from from all
                		Order allow,deny
                 
                		AcceptPathInfo On
                 
                </Directory>
                The key is to have the line "AcceptPathInfo On" defined for some directory at or below where the archive exists.

                == Bill
                THANK YOU! That worked perfectly! .htaccess was not working... and I like this way better

                Comment


                • #38
                  Originally posted by Drowned
                  THANK YOU! That worked perfectly! .htaccess was not working... and I like this way better
                  Fine for those who are running their own servers... not so fun for those paying for server space though!

                  Comment


                  • #39
                    Originally posted by Scott MacVicar
                    mod_rewrite isn't really that scalable so on a large server there will be a performance loss.

                    The problem with CGI's versions is a PHP bug which is in the bug tracker but not yet resolved link http://bugs.php.net/bug.php?id=25047
                    Can you let the PHP team know that many people are waiting for this bug to be fixed?

                    [21 Apr 12:13am CEST] [email protected] No feedback was provided. The bug is being suspended because
                    we assume that you are no longer experiencing the problem.
                    If this is not the case and you are able to provide the
                    information that was requested earlier, please do so and
                    change the status of the bug back to "Open". Thank you.

                    Comment


                    • #40
                      Thomas P, I have a few Q's in relation to the archive/translation.

                      1. Where it says Ersetzen mit: (aka Replace With) - What do we put in stead of the Replace ME! syntax ?
                      2. What does "Suche und lösche die folgende Zeile:" mean? (Step 2)

                      Thanks !

                      Comment


                      • #41
                        someone........anyone ?

                        Comment


                        • #42
                          Sorry, I don't understand the question.
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #43
                            I posted up an English version of the German "Get the Archive to work under CGI" server configuration. Hope it helps.

                            I did this on my system, working fine now, finally. All day with this mess.
                            Attached Files

                            Comment


                            • #44
                              Security Concerns with running PHP as a module?

                              Dreamhost allows me to run PHP as CGI or module, however they HIGHLY recommend CGI for these reasons (https://panel.dreamhost.com/kbase/?area=2933):

                              ---------------------------------------------------------------------
                              There are two ways you can choose to have your PHP executed at DreamHost. The default is as a regular CGI. This is by far the preferred method. The benefits of running PHP-CGI are:
                              • It is more secure. The PHP runs as your user rather than dhapache. That means you can put your database passwords in a file readable only by you and your php scripts can still access it!
                              • It is more flexible. Because of security concerns when running PHP as an Apache module (which means it runs as our dhapache user), we have disabled a number of commands with the non-CGI PHP. This will cause installation problems with certain popular PHP scripts (such as Gallery) if you choose to run PHP not as a CGI!
                              • It's just as fast as running PHP as an Apache module, and we include more default libraries.
                              There are a FEW VERY MINOR drawbacks to running PHP-CGI. They are:
                              • Custom 404 pages won't work for .php files with PHP-CGI.
                              • Variables in the URL won't work without using mod_rewrite (example.com/blah.php/username/info/variable).
                              • Custom php directives in .htaccess files (php_include_dir /home/user;/home/user/example_dir) won't work.
                              • The $_SERVER['SCRIPT_NAME'] variable will return the php.cgi binary rather than the name of your script
                              If one of those is a show-stopper for you, you can easily switch to running PHP as an Apache module and not CGI, but be prepared for a bunch of potential security and ease-of-use issues! If you don't know what any of these drawbacks mean, you're fine just using the default setting of PHP-CGI and not worrying about anything!
                              ---------------------------------------------------------------------

                              So, I'm not sure what to do...I really need to have a text-only version of my vBulletin running and I think that requires using vBulletin's archive feature (which requires running PHP as a module), which apparently has security issues. Any ideas?

                              Has anyone else tried the "Get the Archive to work under CGI" server configuration listed in the previous post? (thanks for that post, by the way...that might be the solution I need)

                              Thanks in advance for any input...
                              Last edited by Mendi; Thu 4th Nov '04, 7:08pm.

                              Comment


                              • #45
                                Originally posted by tfw20051
                                I posted up an English version of the German "Get the Archive to work under CGI" server configuration. Hope it helps.

                                I did this on my system, working fine now, finally. All day with this mess.
                                I have only one question about these instructions and I hope a simple one to answer...

                                where does the .htaccess file need to be saved? in the archive folder, root, forum or none of the above?

                                Comment

                                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                                Working...
                                X