Announcement

Collapse
No announcement yet.

What do I need to make the archive work?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • What do I need to make the archive work?

    I have had to move server, on the old host I never needed to set anything that I am aware of to get the archive link to work. On the new host all I get is a return to the front page of the forum when anyone uses the archive link.

    I have vB beta 7 with no hacks.

  • #2
    You've disabled phpinfo display on your forum so i cant check out exactly what the problem is, however,

    The archive needs Apache and PHP compiled as a module, not CGI, and wont work on IIS.

    In the phpinfo page, you should be able to determin what webserver is running, if you dont already know, and how php is compiled and configured.

    http://www.flipside-forums.co.uk/for...cp/?do=phpinfo

    Check out the 4th(ish) table, it should tell you how its compiled. Mine says "Apache 2.0 Handler" and the archive works.

    Comment


    • #3
      Thanks for the reply Merk,
      I have now set the php info so you can look, the only ref to Apache I could find is as follows

      Apache/1.3.29 (Unix) mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_bwlimited/1.4 FrontPage/5.0.2.2634 mod_ssl/2.8.16 OpenSSL/0.9.6b PHP-CGI/0.1b

      This shows up in a few places, so for a start I don't have the same version by the looks of it, but would that have an effect?

      Comment


      • #4
        Unfortunatly, PHP is compiled on your host as CGI, the archive wont work

        Comment


        • #5
          Haaaaaaaaaaay Merk ... wave'n atcha !!!

          Happy New Year !!!

          My archive isn't working ... any suggestions?

          I have a test forum here ... www.blackself.com/forums/?do=phpinfo

          Thanks a Bunch.

          Destee
          destee.com

          Comment


          • #6
            Sorry Destee, i dont know why your archive wouldnt be working.


            I cant see it "not working" because your forum is closed too.

            Define "not working"?

            Comment


            • #7
              Hi Merk ... sorry about that ... the forum is open now.

              Not working means it is giving me a "Page Not Found" error.

              Thank You.

              Destee
              destee.com

              Comment


              • #8
                IT looks like the AcceptPathInfo is off in the apache configuration. (from the apache manual)
                Off A request will only be accepted if it maps to a literal path that exists. Therefore a request with trailing pathname information after the true filename such as /test/here.html/more in the above example will return a 404 NOT FOUND error.
                Try, putting .htaccess in your main forum directory with the following in it
                Code:
                AcceptPathInfo On
                Im not sure if that will work in .htaccess, though. Just checked the apache 2 documentation, it is settable in .htaccess - http://httpd.apache.org/docs-2.0/mod...acceptpathinfo
                Last edited by merk; Sat 3 Jan '04, 8:25pm. Reason: changed details

                Comment


                • #9
                  Oh My Gosh Merk !!!! You're so Wonderful !!!! Thank You !!!!

                  This is THE MOST important feature of vb3 for me and i am so grateful !!!

                  I just want to say that you have helped me several times in this community, so much so that i have actually posted calling your name (not just this time) ... i was so glad to see you had posted in this thread so i could scream your name again ... i'm sure that the "vB Powers That Be" have noticed your expertise and willingness to share it with everyone ... and your name is at the top of their list for next Moderator in this community! Yep, i'm kinda psychic and i see that coming!

                  Thank You So Very Much Merk !!! My Archive is Working !!!

                  Destee
                  destee.com

                  Comment


                  • #10
                    Good to see that even though I could not be helped that some good came from this thread... congrats!

                    Comment


                    • #11
                      Im flattered, thanks

                      Comment


                      • #12
                        worked for me , cheers !
                        My Sites :

                        Comment


                        • #13
                          wish I could get this working!

                          I've read through all the posts on this forum and am still coming up empty. I have the exact same problem as obove with RC2. When I click archive I get the 404 error, so I took Merk's advice and added the above line to my .htaccess file.

                          After I made the change I now get a 500 Server Error. After some checking in my Apache error log I found this:

                          '.htaccess: AcceptPathInfo not allowed here'

                          DAMN! Anyone seen this problem before? I cannot launch my board until I get the archive system working.

                          After some reading it seems I need to allow vbb to override my apache settings in httpd.conf or this will not work. Unfortunately that is where I am stuck.

                          Does anyone know what needs to be changed in my httpd.conf to allow the AcceptPathInfo option to work?

                          Comment


                          • #14
                            finally!

                            OK after some more Googling I finally got it to work. Here is the solution.

                            First make sure your running Apache 2.0 or better and edit your httpd.conf file. Find the Directory containers listing pertaining to your website. It will look something like this:

                            <Directory "/usr/local/apache/othersites/yourwebsite/">
                            Options Indexes FollowSymLinks MultiViews
                            AllowOverride AuthConfig FileInfo
                            Order allow,deny
                            Allow from all
                            </Directory>

                            The important line is:
                            AllowOverride AuthConfig FileInfo

                            Without the 'AllowOverride FileInfo' directive set you will not be able to Override your settings in an .htaccess file. So that leads us to the final step. Make a .htaccess file in your vbb/archive directory and put this line in it:

                            AcceptPathInfo On

                            The archive system with VB3 should now work properly.

                            Comment


                            • #15
                              You're all great.

                              Just moved to a new server, no archive!!

                              Added the .htaccess file. All is groovy..
                              Trained Monkeys

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X