Announcement

Collapse
No announcement yet.

what would happen after upgrade?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • what would happen after upgrade?

    I made a lot of mods and I am stuck at version 2.21. I am willing to loose all the customizations and keep it clean, except for header and footer, just so I could upgrade easily in the future. What would happen if I get the latest version 3 and upload it all in the forum folder? I do not want to mess up my current database.

  • #2
    You first need to backup your database then upgrade to 2.3.3.

    http://www.vbulletin.com/members/upgrade.html

    Then to upgrade to 3.0 Gamma you would need to run upgrade.php to upgrade your database to vB3. None of your vB2 templates will work in vB3 so you will need to redo the changes to your header and footer templates.

    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      I copied my database into something else to play it safe. I did the samething for entire 2.21 forums. I am trying to make sure it is all fine before I make the real upgrade. I ran all the different upgrades up to 2.33. I try to run upgrade.php without realizing that I had to reput the db info. I fixed that and and At step1 it tells me:
      We have detected that you have already tried to run the upgrade script. You will not be able to proceed unless you revert to a vB 2.2.x database.

      Comment


      • #4
        As the message says you need to restore the vB 2.x database.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          you made me upgrade up to 2.33

          Comment


          • #6
            Yes, but as the message says you tried running the upgrade script once nefore and stopped. Did you make a backup of your database prior to starting the upgrades? Unfortunately you will need to restore this backup and start again from the beginning.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X