Announcement

Collapse
No announcement yet.

Cannot Upgrade

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Steve Machol
    replied
    That would seem to be it. Unfortunately I've seen other problems with the table and have not seen a solution. Try reuploading all the original Gamma files and trying again.

    Edit: Hmmm...very strange.

    Leave a comment:


  • freedom2support
    replied
    Strange, It just suddenley worked, hit reload on upgrade.php and after about 10 attempts the upgrade.php script came up without an error, seems to be resolved, but seems very very odd.

    Leave a comment:


  • freedom2support
    replied
    The Database exists yep, because I've used exactly the same details for my existing 2.3.3 board and it works fine, the table doesn't though, and I thought I read it's not needed in 2.3.3, could it be that the table is not being created?

    Leave a comment:


  • Steve Machol
    replied
    Originally posted by freedom2support
    mysql error: Table 'freedom2support_net_-_vb3.datastore' doesn't exist
    Does that database and table exist?

    Leave a comment:


  • freedom2support
    replied
    Also to prove it's something with the installer, the existing vb 2.3.3 will run off both my live database, and also the seperate one that contains a backup that I want to use on VB3 to test it out.

    I simply get the above error when I try to run my upgrade script, more info below :

    Database error in vBulletin :

    Invalid SQL:
    SELECT title, data FROM datastore
    WHERE title IN ('options', 'cron', 'forumcache', 'usergroupcache', 'stylecache')

    mysql error: Table 'freedom2support_net_-_vb3.datastore' doesn't exist

    mysql error number: 1146

    Date: Sunday 21st of December 2003 05:59:16 PM
    Script: http://www.freedom2support.net/testv...ll/upgrade.php
    Referer:
    IP Address: 81.174.150.99
    Last edited by freedom2support; Sun 21 Dec '03, 10:00am.

    Leave a comment:


  • freedom2support
    started a topic Cannot Upgrade

    Cannot Upgrade

    It seems to be impossible to do so, I have a second database set up which contains a backup of my live database, I have set up a second database with a copy of my date in so I can play around with vb3 in a testing environment so when I have it skinned etc, I can go live with it and replace my existing vb 2.3.3

    I've simply SSH'd a backup to my webspace, and restored it in a second database, and then set the various config options in the config file to use the correct data/username/password/database name for this second database, however when I run the upgrader I get this:

    There seems to have been a slight problem with the database.
    Please try again by pressing the refresh button in your browser.

    An E-Mail has been dispatched to our Technical Staff, who you can also contact if the problem persists.

    We apologise for any inconvenience.

    I have the database settings in config.php pointing to the database with the backup of my VB2.3.3 installation in, if I change the config.php in vb2.3.3 to use the same details it runs off the second database fine, but as soon as I fire up the upgrade script for vb3 with the same details, it doesn't work, just a database error, please advise.
    Last edited by freedom2support; Sun 21 Dec '03, 9:52am.
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X