Announcement

Collapse
No announcement yet.

Cannot scroll down the page when showthread is loading while logged in

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • M1th
    replied
    indeed.

    Leave a comment:


  • MJM
    replied
    I hope that this is considered a bug and is fixed for the next release.
    This timelag...waiting for thread to open...issue is the main reason I'm holding back from upgrading our forums.
    Mark

    Leave a comment:


  • scifi-meshes
    replied
    Worked for me also: THIS is the coding

    In showthread_quickreplay:

    <!-- set up CSS for the editor -->
    <!-- COMMENTED OUT <link rel="stylesheet" type="text/css" href="$vboptions[abspath]/clientscript/vbulletin_editor.css" /> -->
    <style type="text/css">

    Added in headerinclude: (at the bottom)

    <link rel="stylesheet" type="text/css" href="$vboptions[abspath]/clientscript/vbulletin_editor.css" />

    And things worked perfectly. Make sure IF you comment out using <!-- --> that you put the closing "-->" before the line "<style type="text/css">" othewise you'll get display errors.

    Aceman, with special thanks to Seanr for showing me where too look.. and Slave for testing it out.

    Leave a comment:


  • Slave
    replied
    Originally posted by Slave
    hmm .. very interesting .. good catch

    If that's the case .. what would the best place be to put that bit of code? .. I can't see people wanting that .css file loading on every page so is there a header bit of code that is only shown on showthread that we could put it in? or wouldn't it matter if it loaded in every page?

    /me is a complete css n00b .. !
    following on with that .. I took ..

    Code:
    <link rel="stylesheet" type="text/css" href="$vboptions[abspath]/clientscript/vbulletin_editor.css" />
    out of "showthread_quickreply" and put it into "headinclude" .. see image for where I put it in the code ..

    Seems to work .. the thread now loads without the problem .. the only thing I would say is that the quickquote box seems to take a while to load .. but this might of been the case anyway and I've just not noticed it due to not being able to scroll down to it ..
    Attached Files

    Leave a comment:


  • Slave
    replied
    hmm .. very interesting .. good catch

    If that's the case .. what would the best place be to put that bit of code? .. I can't see people wanting that .css file loading on every page so is there a header bit of code that is only shown on showthread that we could put it in? or wouldn't it matter if it loaded in every page?

    /me is a complete css n00b .. !

    Leave a comment:


  • scifi-meshes
    replied
    After about an hour and a half of extensive detective work, I figured out what is causing the scroll to not work correctly while the thread screen is loading (the bar doesn't work and the mouse wheel screws the entire display up). The problem is caused by using a link tag to load an external CSS file near the bottom of hte page:

    FOUND IN TEMPLATE: showthread_quickreply

    <!-- set up CSS for the editor -->
    <link rel="stylesheet" type="text/css" href="$vboptions[abspath]/clientscript/vbulletin_editor.css" />
    <style type="text/css">

    If you move that into the head area, the problem goes away. As soon as you move it back, it comes back again, no matter what is actually inside of the CSS file. Apparently IE does not like loading CSS files after it's already started displaying the page.

    The above code is about 20 lines below the Prev Thread and Next Thread links. The CSS code right below that line does not cause any problems at all, only the external linked file. In fact, removing the link altogether and copying the code contained within it directly into the page along with the other CSS code in that spot does not cause any problems - it's the link tag itself, not what's in the CSS file that's breaking the page.

    Hope that helps (and hope to see it fixed soon)!

    - PROVIDED BY A MEMBER OF MY FORUMS -

    Suggestions on how to correct this would be appreciated.
    Last edited by scifi-meshes; Thu 18th Dec '03, 4:32am.

    Leave a comment:


  • Slave
    replied
    Originally posted by KeithMcL
    I'm using IE6 on XP and this happens to me on SitePoint's forums and they're using beta 7. It did used to happen here but doesn't seem to anymore. My forums are using beta 6 and it doesn't happen there. It must be something to do with the wysiwyg editor preferences of the user.
    Well .. it was deffo happening to me on these forums after they upgraded to Gamma .. but for the last couple of days it's stopped happening .. and that's with me always using the standard input boxes ..

    So something has changed on these forums ..... it would be nice to know what so we can get our own forums updated ..

    Leave a comment:


  • KeithMcL
    replied
    Originally posted by Erwin
    Well, it wasn't a problem in Beta 7, so obviously something has changed to cause this. It is rather annoying. Considering that most users use IE, the upgrade to Gamma has caused lots of consternation, especially amongst those with slow connections.

    Is there a possible fix for this? Something to remove in the JS?
    I'm using IE6 on XP and this happens to me on SitePoint's forums and they're using beta 7. It did used to happen here but doesn't seem to anymore. My forums are using beta 6 and it doesn't happen there. It must be something to do with the wysiwyg editor preferences of the user.

    Leave a comment:


  • matthepepe
    replied
    I noticed it has gone away on these forums too... it was so bad at first i had IE crash on me at work .

    Leave a comment:


  • Mike Warner
    replied
    Any gen. on this as I am no longer getting it either.

    Leave a comment:


  • Slave
    replied
    Following on from that .. it seems like I'm not getting it any more on these forums ..

    Has something been done to improve it?

    Leave a comment:


  • Slave
    replied
    It seems to be worse if you have standard/wysiwyg quick reply enabled .. with a standard text box it is better but you still get it, just not for so long ..

    Leave a comment:


  • Mike Warner
    replied
    I'm getting this too - very annoying.

    Leave a comment:


  • Erwin
    replied
    Originally posted by tubedogg
    As Mike said, it's a known IE issue. There's not really anything we can do about it.
    Well, it wasn't a problem in Beta 7, so obviously something has changed to cause this. It is rather annoying. Considering that most users use IE, the upgrade to Gamma has caused lots of consternation, especially amongst those with slow connections.

    Is there a possible fix for this? Something to remove in the JS?

    Leave a comment:


  • tubedogg
    replied
    As Mike said, it's a known IE issue. There's not really anything we can do about it.

    Leave a comment:

Related Topics

Collapse

  • josh-v
    Slow page loads
    by josh-v
    We have a sub-forum where each topic is a private communication thread between a client and a handful of coaches who provide online coaching. When clicking the double arrows to go to the last post of...
    Thu 20th Oct '16, 1:33pm
Working...
X